Ionic 4 installed app but missing app launcher, what

I’ve been developing to my usb connected phone for almost a month now, the app once deployed on my phone would stay there on the home screen like any other app, but I just suddenly realized that literally right now, MyApp is installed on my device, if I go to installed Apps, but it doesn’t appear on the home screen of my android device, the app launcher is literally gone, uninstalled the app and cleared phone, built and deployed it again to my device, same thing, MyApp launches when I deploy and it works perfectly, I can swap windows, go to google for instance and then swap to the MyApp again, but if I really close MyApp, I can’t find any launcher to open the app again, never seen something like this before, what do I do

Are you using something like ionic cordova build android?
There should be a message like

[cordova] Built the following apk(s):
[cordova] (your repository path)\platforms\android\app\build\outputs\apk\debug\app-debug.apk

If so you can go to the folder and import the APK to your phone and install it

the command I run is
ionic cordova run android --device
and it builds the app and then installs it into my phone, the app would stay there as any other app, but now the app is deployed to my phone but it’s not staying, if I close it then I can’t open it anymore cuz I dont find the launcher, but app is installed in phone

I run on my emulator with
ionic cordova run android -l (livereload)
but it installs the apk as soon as it launches the emulator
You browsed through all your apps as well right?
If so my best solution will only be to manually move the apk from your PC to your phone

Hey,

i was also having same issue and was looking what to do next. thank you for your replies, it helped me a lot.

best regards!!!

My phone is the kind that makes you have all apps icons on the home page, either if you want it or not.
Before when I used that command it used to create the launcher on the home page right away and open up the app, I could close the app and open the app again from the launcher, now i know the app is installed since it appears in the “phone settings - installed apps” but no launcher is created on the home page, so if I close it I cant open it anymore
I went to the “seach app” feature of my phone and when I enter MyApp nothing appears, I really don’t know why would this be happening
About what you said, I’m sure that if I build the app instead of running it, and then manually install the apk then it won’t happen anymore, but thing is, I don’t wanna be doing that all the time, I want to run the app and I want it to install normally like before

Yeap… that’s what I thought too, it would be too tedious to do that way all the time
But that’s the best solution I could give for now :crazy_face: