Ionic run android does not install app in device

Hi, I’m using ionic for writting an android app, but I can’t istall it using ionic run android.

The output of this command says at the end


Total time: 4.27 secs
Built the following apk(s):
Using apk:      /home/xx/ionics/platforms/android/build/outputs/apk/android-debug.apk
Installing app on device...
Launching application...

Same when I use cordova run android instead.

Right now I have to install it using adb install, and also I have to uninstall the app and reinstall it with adb for viewing changes.

I’m using a Samsung Galaxy Tab GT-P3110 Android v 4.0.3

Is this a device issue? what could I do for solving it?

Thanks for any help


I have the same problem, but using cordova, hope to find a solution.

1 Like

Hi, found a solution here.

$ ionic run android --target=<device_id>

where device_id is the code obtained with

$ adb devices


Tried @vprogramador’s advice and it did not solve the problem here. Any other solution?

1 Like

Same issue for me. Anyone found the solution?

I can’t test on an emulator either. The only way to see my app is the use IonicView which is highly inconvenient and time consuming, doesn’t provide the way to reload the application.

The debugging mode on my Android device is turned on and the install from unknown sources in turned on as well. I have no clue what’s going on - it worked before.

Any tips much appreciated.


At the end of the ionic run android command, copy the full path to the .apk file that it shows, then enter:

adb -d install /path/to/the/apk/file.apk

The app will be installed, and if you run it, then repeat your ionic run android command with -l, even the interactive shell and debug console will work with the manually launched instance on your phone.

1 Like

Somebody offers a fix here:

(via )



Its very weird. I had the issue on a HP tablet device, but ionic run android worked just fine on a Samsung Galaxy S3, so I guess it depends on the device.

I just created a new project and ran into this same problem, using a Samsung Galaxy s3.

ionic run android --device fixed it for me. i am using galaxy note 4

1 Like

I’m not sure about that issue, but this is my workflow. Build APK, move apk to dropbox either manually or using a program that watches the output folder and copies directly into Dropbox (Belvedere or Hazel). Then just go into the Dropbox app and install from there. No cables and easy to install and test on multiple devices or across a team or testers.

A side note if your app actually wont install, if you’ve got more than one signing key, you’ve got to uninstall and reinstall the app fresh, rather than just installing it over the existing app.

ionic run android not running on android 3.1 API

hmm I’ve tried this … but no luck

I understand that the following suggestion “sounds” crazy, but if definitely works for the device I am testing on here: EVO BLU 4G.

Unplug the USB from the phone port itself, and then back in. Unplugging the USB cable from the computer end does not cause the device to register with adb.

Perhaps the phone has some way of knowing whether you’ve connected a device to the USB micro port regardless of whether the other end establishes any actual connection. But perhaps more likely is a physical defect in the cable/phone that makes plugging it into the device “iffy”.