Android app launch success but app is not installed on device

#1

I have successfully installed the app on device and everything worked just fine. But after i deleted the app from device and tried ionic cordova run android again, the app is not installed on device anymore but work perfectly on emulator.

BUILD SUCCESSFUL

Total time: 2.359 secs

E:\Ionic\travelApp>if "0" == "0" goto mainEnd

E:\Ionic\travelApp>if "Windows_NT" == "Windows_NT" endlocal
Command finished with error code 0: cmd /s /c "E:\Ionic\travelApp\platforms\android\gradlew.bat cdvBuildDebug -b E:\Ionic\travelApp\platforms\android\build.gradle -Dorg.gradle.daemon=true -Dorg.gradle.jvmargs=-Xmx2048m -Pandroid.useDeprecatedNdk=true"
Built the following apk(s):
        E:/Ionic/travelApp/platforms/android/build/outputs/apk/android-debug.apk
No scripts found for hook "before_deploy".
ANDROID_HOME=C:\Users\User\AppData\Local\Android\sdk
JAVA_HOME=C:\Program Files\Java\jdk1.8.0_102
Running command: C:\Users\User\AppData\Local\Android\sdk\platform-tools\adb.exe devices
Command finished with error code 0: C:\Users\User\AppData\Local\Android\sdk\platform-tools\adb.exe devices
No target specified, deploying to device '8UEDU17B22003225'.
Running command: C:\Users\User\AppData\Local\Android\sdk\platform-tools\adb.exe devices
Command finished with error code 0: C:\Users\User\AppData\Local\Android\sdk\platform-tools\adb.exe devices
Running command: C:\Users\User\AppData\Local\Android\sdk\platform-tools\adb.exe devices
Command finished with error code 0: C:\Users\User\AppData\Local\Android\sdk\platform-tools\adb.exe devices
Running adb shell command "cat /proc/cpuinfo" on target 8UEDU17B22003225...
Running command: C:\Users\User\AppData\Local\Android\sdk\platform-tools\adb.exe -s 8UEDU17B22003225 shell cat /proc/cpuinfo
Command finished with error code 0: C:\Users\User\AppData\Local\Android\sdk\platform-tools\adb.exe -s,8UEDU17B22003225,shell,cat,/proc/cpuinfo
Skipping build...
Built the following apk(s):
        E:/Ionic/travelApp/platforms/android/build/outputs/apk/android-debug.apk
Using apk: E:/Ionic/travelApp/platforms/android/build/outputs/apk/android-debug.apk
Package name: io.ionic.starter
Installing apk E:/Ionic/travelApp/platforms/android/build/outputs/apk/android-debug.apk on target 8UEDU17B22003225...
Running command: C:\Users\User\AppData\Local\Android\sdk\platform-tools\adb.exe -s 8UEDU17B22003225 install -r E:/Ionic/travelApp/platforms/android/build/outputs/apk/android-debug.apk
Command finished with error code 0: C:\Users\User\AppData\Local\Android\sdk\platform-tools\adb.exe -s,8UEDU17B22003225,install,-r,E:/Ionic/travelApp/platforms/android/build/outputs/apk/android-debug.apk
Running adb shell command "input keyevent 82" on target 8UEDU17B22003225...
Running command: C:\Users\User\AppData\Local\Android\sdk\platform-tools\adb.exe -s 8UEDU17B22003225 shell input keyevent 82
Command finished with error code 0: C:\Users\User\AppData\Local\Android\sdk\platform-tools\adb.exe -s,8UEDU17B22003225,shell,input,keyevent,82
Starting application "io.ionic.starter/.MainActivity" on target 8UEDU17B22003225...
Running adb shell command "am start -W -a android.intent.action.MAIN -nio.ionic.starter/.MainActivity" on target 8UEDU17B22003225...
Running command: C:\Users\User\AppData\Local\Android\sdk\platform-tools\adb.exe -s 8UEDU17B22003225 shell am start -W -a android.intent.action.MAIN -nio.ionic.starter/.MainActivity
Command finished with error code 0: C:\Users\User\AppData\Local\Android\sdk\platform-tools\adb.exe -s,8UEDU17B22003225,shell,am,start,-W,-a,android.intent.action.MAIN,-nio.ionic.starter/.MainActivity
LAUNCH SUCCESS
No scripts found for hook "after_run".
1 Like
#2

I have the same issue. Please let me know if you find the solution.

#3

In your project, go to platforms\android\build\outputs\apk and you will find .apk file. Simply drag the file into any folder of your device and run the file from the device.