I tried to install a lib with bower and I get an error message on angular version.
I am confused, can you help me figure this out ?
$ bower install ionic-modal-select
Unable to find a suitable version for angular, please choose one:
1) angular#1.2.29 which resolved to 1.2.29 and is required by angular-animate#1.2.29, angular-sanitize#1.2.29
2) angular#~1.2.17 which resolved to 1.2.29 and is required by ionic#1.0.0-beta.13
3) angular#~1.4.1 which resolved to 1.4.7 and is required by angular-pouchdb#3.0.0
4) angular#>= 1.0.8 which resolved to 1.4.7 and is required by angular-ui-router#0.2.10Prefix the choice with ! to persist it to bower.json
? Answer:: 3
bower install angular-pouchdb#3.0.0
bower install ionic#1.0.0-beta.13
bower install collide#1.0.0-beta.3
bower install ionic-modal-select#1.0.0
bower install angular#1.4.7
bower install pouchdb#4.0.3
bower install angular-ui-router#0.2.10
bower install angular-sanitize#1.2.29
bower install angular-animate#1.2.29
throw er; // Unhandled 'error' event
Error: ENOSPC, write
@yurinondual is right but to come back to your original problem, if you use ionic 1.1.0 you can use angularjs 1.4.7 and if your app is running on iOS 9 you should at least use 1.4.6 as it includes patches for this version.
I downloaded the last ionic version (1.1.0= from the website, unzipped it in www/lib/ionic, changed the version to 1.1.0 in my bower.json in the root dir of my app and did ionic lib update again. This time it works.
I usually edit my bower.json and then run bower update but I don’t use ionic starters so maybe there are better ways. I rather use usual tools for angular development such as what generator-m-ionic offers.