Which angular version should I use


I tried to install a lib with bower and I get an error message on angular version.
I am confused, can you help me figure this out ?


$ bower install ionic-modal-select
Unable to find a suitable version for angular, please choose one:
    1) angular#1.2.29 which resolved to 1.2.29 and is required by angular-animate#1.2.29, angular-sanitize#1.2.29 
    2) angular#~1.2.17 which resolved to 1.2.29 and is required by ionic#1.0.0-beta.13 
    3) angular#~1.4.1 which resolved to 1.4.7 and is required by angular-pouchdb#3.0.0 
    4) angular#>= 1.0.8 which resolved to 1.4.7 and is required by angular-ui-router#0.2.10Prefix the choice with ! to persist it to bower.json

? Answer:: 3
bower install       angular-pouchdb#3.0.0
bower install       ionic#1.0.0-beta.13
bower install       collide#1.0.0-beta.3
bower install       ionic-modal-select#1.0.0
bower install       angular#1.4.7
bower install       pouchdb#4.0.3
bower install       angular-ui-router#0.2.10
bower install       angular-sanitize#1.2.29
bower install       angular-animate#1.2.29

        throw er; // Unhandled 'error' event
Error: ENOSPC, write

If you simply google your error Error: ENOSPC, write you can see that it is nothing to do with the version of angular you chose, it is saying taht you ran out of space in your /tmp folder

@yurinondual is right but to come back to your original problem, if you use ionic 1.1.0 you can use angularjs 1.4.7 and if your app is running on iOS 9 you should at least use 1.4.6 as it includes patches for this version.

Thanks but I am using

$ ionic -v

This is not ionic version, this is ionic cli version.
To know which version of ionic framework you use, have a look at the bower.json file in your project.

oh ok, apparently I am using : “ionic”: “driftyco/ionic-bower#1.0.0-beta.13”

What should I do, should I upgrade ?

Yes you should upgrade as you would not want to go live with a beta version.

Thanks @gmarziou, can you tell me the best-practice way to upgrade ? (because if I understand sudo npm update -g ionic only upgrades the CLI).
I just tried

ionic lib update

and I get this error:

 bower                        ECONFLICT Unable to find suitable version for angular

Here’s my bower.json:

 "name": "BoardLine",
  "private": "true",
  "devDependencies": {
    "ionic": "driftyco/ionic-bower#1.0.0-beta.13",
    "angular-pouchdb": "~3.0.0"
  "dependencies": {
    "angular-pouchdb": "~3.0.0"

By the way, are you a Ionic developper in France ?

I downloaded the last ionic version (1.1.0= from the website, unzipped it in www/lib/ionic, changed the version to 1.1.0 in my bower.json in the root dir of my app and did ionic lib update again. This time it works.

I usually edit my bower.json and then run bower update but I don’t use ionic starters so maybe there are better ways. I rather use usual tools for angular development such as what generator-m-ionic offers.


Ok thanks I updated my bower.json file to ionici 1.1.0, and I ran ionic lib upate. It works now.