Ionic lib update - ECONFLICT Unable to find suitable version for angular


#1

Hello,

I encounter this error:

C:\Users\Go\Dev\MyProject>ionic lib update
bower ionic#1.0.0-beta.13       cached git://github.com/driftyco/ionic-bower.git#1.0.0-beta.13
bower ionic#1.0.0-beta.13     validate 1.0.0-beta.13 against git://github.com/driftyco/ionic-bower.git#1.0.0-beta.13
bower angular#>=1.0.0 <1.4.0    cached git://github.com/angular/bower-angular.git#1.3.7
bower angular#>=1.0.0 <1.4.0  validate 1.3.7 against git://github.com/angular/bower-angular.git#>=1.0.0 <1.4.0
bower angular#~1.3.1            cached git://github.com/angular/bower-angular.git#1.3.7
bower angular#~1.3.1          validate 1.3.7 against git://github.com/angular/bower-angular.git#~1.3.1
bower angular#1.2.23            cached git://github.com/angular/bower-angular.git#1.2.23
bower angular#1.2.23          validate 1.2.23 against git://github.com/angular/bower-angular.git#1.2.23
bower angular#~1.2.17           cached git://github.com/angular/bower-angular.git#1.2.28
bower angular#~1.2.17         validate 1.2.28 against git://github.com/angular/bower-angular.git#~1.2.17
bower angular#1.2.26            cached git://github.com/angular/bower-angular.git#1.2.26
bower angular#1.2.26          validate 1.2.26 against git://github.com/angular/bower-angular.git#1.2.26
bower angular#>= 1.0.8          cached git://github.com/angular/bower-angular.git#1.3.7
bower angular#>= 1.0.8        validate 1.3.7 against git://github.com/angular/bower-angular.git#>= 1.0.8
bower ECONFLICT Unable to find suitable version for angular
===========================================================

Do you have ny idea hat is the issue ?
Thank you


#2

Everytime I install a new Ionic release I have to change permissions, like:

cd to parentfolder containing the ionic folder
chmod -R 777 ionic

hope this helps


#3

thank you for your answer, unfortunately I have the same issue.


#4

read this topic and see if it can help you "ionic lib update" provides corrupted files


#5

@ronycohen I dont use bower to install ionic.

I download the zip from github and unzip this in my www.lib folder. Then to avoid permissionproblems do:

cd www/lib chmod 755 -R ionic


#6

I had this issue yesterday to solve it I did: bower install ionic#1.0.0-beta.14, then when it asked for a conflict resolution I always picked Angular 1.3.x. If I remember correctly that was the only thing I had to do. Then I updated the main bower.json file with the new version of Ionic.


#7

I just want to revive this thread because I think it deserves a better answer.

The most likely reason for this error is that when using ionic lib update the subsequent bower call is wrapped by ionic. This causes interactive mode to be off. Therefore the ionic lib update just exits with error because it never gets the input it needs.

You will likely get over this problem if you just run bower update.


#8

I was unable to resolve this issue with bower update for a particular project. In the end, I removed the bower.json file located in www/lib/ionic and then performed a ionic lib update at the root of the project. I was then asked if I wanted to update and I selected ‘y’. It may not be the best workaround, but it seems to have worked for me.


#9

The response by @tobiaswk helped me. One thing I would add to it though is that when you run bower update and the cli interactively asks you to choose how to resolve the angular conflict make sure you prefix your response with !. This will make sure that your choice is propagated to bower.json. Without this you will keep running into the problem.


#10

It is the trick! Now it is solved. Thanks!