ngCordova - unable to find a suitable angular version


#1

I have the following in bower.json:

"dependencies": {
    "ionic": "driftyco/ionic-bower#master",

The angular version that comes with that seems to be AngularJS v1.2.26-build.483+sha.038ca9b

I’ve updated bower and was trying to install ngCordova, but I’m getting the following error, does anyone know what’s wrong?

Unable to find a suitable version for angular, please choose one:
    1) angular#1.2.0 which resolved to 1.2.0 and has ngCordova#0.1.4-alpha as dependants
    2) angular#~1.2.17 which resolved to 1.2.26-build.483+sha.038ca9b and has ionic#db0535ef7d as dependants
    3) angular#1.2.26-build.483+sha.038ca9b which resolved to 1.2.26-build.483+sha.038ca9b and has angular-sanitize#1.2.26-build.483+sha.038ca9b as dependants
    4) angular#>= 1.0.8 which resolved to 1.3.0-rc.3 and has angular-ui-router#0.2.10 as dependants
    5) angular#>=1.0.0 <1.4.0 which resolved to 1.3.0-rc.3 and has angular-moment#0.8.2 as dependants

I tried selecting option 2 as that is the version that’s currently loaded by ionic as well, but that triggers warnings like this when updating through bower:

Please note that,
    ngCordova#0.1.4-alpha depend on angular#1.2.0 which resolved to 1.2.0
    angular-animate#1.2.26-build.483+sha.038ca9b, angular-sanitize#1.2.26-build.483+sha.038ca9b depend on angular#1.2.26-build.483+sha.038ca9b which resolved to 1.2.26-build.483+sha.038ca9b
    ionic#db0535ef7d depend on angular#~1.2.17 which resolved to 1.2.26-build.483+sha.038ca9b
    angular-moment#0.8.2 depend on angular#>=1.0.0 <1.4.0 which resolved to 1.3.0-rc.3
    angular-ui-router#0.2.10 depend on angular#>= 1.0.8 which resolved to 1.3.0-rc.3

It would be nice to have a smooth installation of ngCordova together with ionic, maybe the angular dependency is just not set right for ngCordova?


#2

@jorre How about using latest beta ?

just change

"ionic": "driftyco/ionic-bower#master"

to

"ionic": "v1.0.0-beta.13"

#3

With my bower.json file, I already have the latest beta: “version”: “1.0.0-beta.13-nightly-504”,


#4

I think there a dependency issue, both on ngCordova & ionic

I just changed my bower to

"ionic": "v1.0.0-beta.13",
"ngCordova": "0.1.3-alpha",

and updated smoothly


#5

that will probably work, but wouldn’t it be better if we could just run bower update without manually setting versions? Just looking for a smooth workflow here :slight_smile: