Ionic serve doesn't show anything


#1

i tried to load my ionic 2 app in browser, the page seems that load but i don’t see anything, blank page with the title of the app on head. the console not shows anyerror and cmd look good.
it just happen today.
anyone show this problem today?


#3

@adirzoari, Can you please share your code?


#4

just try to reload the page.

I have this time to time during development… ionic service creates the new resources, but the browser refresher does not work correctly and shows an empty page after that.


#5

yes but i have big project, what code to share? i don’t have any error on my page


#6

@codestellar


cmd


#7

what to do then?
have you solve this problem?


#8

Do you see any errors on the console in the browser?


#9

it’s happen to me when i forget to install some plugin wich i gone use.
In device works fine?


#10

no i don’t see any error but i notice that everytime i run “ionic serve” it delete my fonts folder from "assets/fonts/


#11

in device i see it but login page not works good. i tried to log in without sucees.
but in my browser when i see the page, the log in works fine.


#12

too lack of information to help u


#13

i just record my screen to let you see https://www.youtube.com/watch?v=krCibsE3eog


#14

@adirzoari, can you please delete node_modules and do npm install again?
I could see type script version, but please ensure the rest as well.


#15

ionic rc0 based on node 6, try using node 6


#16

i have node 6 but still same problem


#17

thank you for interest,
i did exactly what you did,
in chrome it’s doesn’t work, in explorer i see the app.why is that?


#18

run ionic info comand and past output here
what is the chrome version
can you show screen shot of it with dev tool open


#20

@codestellar

i run ionic info i get is

Your system information:

Cordova CLI: 6.3.1
Ionic Framework Version: 2.0.0-rc.0
Ionic CLI Version: 2.1.0
Ionic App Lib Version: 2.1.0-beta.1
OS:
Node Version: v6.7.0

i add the photo i compare between chrome and explorer
i have the latest version in chrome and it not works, but in explorer it works.


#21

not sure @adirzoari fore me ionic rc0 apps are working fine. I hope you are using typescript version 2.0.3


#22

yes i use.
i get this errror now
Ionic is not recognized as an internal or external command
look on this issue