Ionic Package Frozen with No Build Logs


#1

So I’ve been working on a feature branch and finally pushed my changes up to my master branch. Now, I’ve gone and initiated an ios build using the ionic package service, but it seems that the build has hung up and now I’m waiting to see what happens…

I also cannot start any other builds as it says that “There was an error while submitting your native build. Existing job in queue”.

I never had issues doing builds on my feature branch. Logs would immediately pop up and it would take about 10-15 mins to complete. But now, nothing is showing up. Anything I can do on my end? Also, I’m migrating my app from ionic cloud to ionic pro, and that fact that I can no longer use the CLI to fire off remote builds have completely ruined our CI builds at work.


#2

Looks like the build finished after about an hour, but it was kind of annoying that no logs popped up until the end. Is there value in discussing this further? Anyone from ionic can chime in?


#3

I have the same problem, but it didn’t finished after 4 hours, still the same.


#4

I have this problem as well today. The same thing happened about 2 weeks ago as well. I submitted a support request for it and about 24 hours later it was resolved with intervention on Ionic’s side. They had to reset something on the build queue before I could continue building any further packages.


#5

Anything new about this issue? Still the same behaviour for me. Build is in state “Created” since more than 4 hours now.


#6

Thanks for the replies everyone! At least I know that this isn’t an issue that is exclusive to me. It seems today that I fired off another build and I’m no longer having the “logless” build state that I was experiencing earlier. I wonder if it was a change on their end that fixed my issue. Regardless, it would be nice to see if an ionic dev could give insight to why this would occur.


#7

I’ve contacted support yesterday and they replied they fixed it.
It is working for me this morning.