Ionic 2 update framework


#1

Hi team, i need a help.

I create a project that has the framework, when i make IONIC INFO, the follow settings show me:

Cordova CLI: 6.4.0
Ionic Framework Version: 2.0.0-beta.11
Ionic CLI Version: 2.1.13
Ionic App Lib Version: 2.1.7

In another project that I create today and I am use the component FAB to show buttons action: http://ionicframework.com/docs/v2/components/#fabs

in this project when i make IONIC INFO, the follow settings show me:

Cordova CLI: 6.4.0
Ionic Framework Version: 2.0.0-rc.3
Ionic CLI Version: 2.1.13
Ionic App Lib Version: 2.1.7

now in my first project i need use the same component, but it doesnt work. How to do update the my first app framework to work this component ?

thanks team.


#2

I tried to use, npm install ionic-angular@latest, but this error show me:

ionic-conference-app@ C:\Users\Jhonata\madre-app
├── UNMET DEPENDENCY @angular/common@2.0.0-rc.4
├── UNMET DEPENDENCY @angular/compiler@2.0.0-rc.4
├── UNMET PEER DEPENDENCY @angular/compiler-cli@2.1.1
├── UNMET DEPENDENCY @angular/core@2.0.0-rc.4
├── UNMET DEPENDENCY @angular/forms@0.2.0
├── UNMET DEPENDENCY @angular/http@2.0.0-rc.4
├── UNMET DEPENDENCY @angular/platform-browser@2.0.0-rc.4
├── UNMET DEPENDENCY @angular/platform-browser-dynamic@2.0.0-rc.4
├── UNMET PEER DEPENDENCY @angular/platform-server@2.1.1
├── ionic-angular@2.0.0-rc.3
├── UNMET DEPENDENCY rxjs@5.0.0-beta.6
└── UNMET DEPENDENCY zone.js@0.6.12

npm WARN EPEERINVALID ionic-angular@2.0.0-rc.3 requires a peer of @angular/commo
n@2.1.1 but none was installed.
npm WARN EPEERINVALID ionic-angular@2.0.0-rc.3 requires a peer of @angular/compi
ler@2.1.1 but none was installed.
npm WARN EPEERINVALID ionic-angular@2.0.0-rc.3 requires a peer of @angular/compi
ler-cli@2.1.1 but none was installed.
npm WARN EPEERINVALID ionic-angular@2.0.0-rc.3 requires a peer of @angular/core@
2.1.1 but none was installed.
npm WARN EPEERINVALID ionic-angular@2.0.0-rc.3 requires a peer of @angular/forms
@2.1.1 but none was installed.
npm WARN EPEERINVALID ionic-angular@2.0.0-rc.3 requires a peer of @angular/http@
2.1.1 but none was installed.
npm WARN EPEERINVALID ionic-angular@2.0.0-rc.3 requires a peer of @angular/platf
orm-browser@2.1.1 but none was installed.
npm WARN EPEERINVALID ionic-angular@2.0.0-rc.3 requires a peer of @angular/platf
orm-browser-dynamic@2.1.1 but none was installed.
npm WARN EPEERINVALID ionic-angular@2.0.0-rc.3 requires a peer of @angular/platf
orm-server@2.1.1 but none was installed.
npm WARN EPEERINVALID ionic-angular@2.0.0-rc.3 requires a peer of rxjs@5.0.0-bet
a.12 but none was installed.
npm WARN EPEERINVALID ionic-angular@2.0.0-rc.3 requires a peer of zone.js@~0.6.2
6 but none was installed.

Ok, I tried update in separed, but it doenst work, somebody knows how to this?

My versions here:

NPM OUTDATED:

Package Current Wanted Latest Location
@angular/common MISSING 2.0.0-rc.4 2.2.3 ionic-conf
erence-app
@angular/compiler MISSING 2.0.0-rc.4 2.2.3 ionic-conf
erence-app
@angular/core MISSING 2.0.0-rc.4 2.2.3 ionic-conf
erence-app
@angular/forms MISSING 0.2.0 2.2.3 ionic-conf
erence-app
@angular/http MISSING 2.0.0-rc.4 2.2.3 ionic-conf
erence-app
@angular/platform-browser MISSING 2.0.0-rc.4 2.2.3 ionic-conf
erence-app
@angular/platform-browser-dynamic MISSING 2.0.0-rc.4 2.2.3 ionic-conf
erence-app
@angular/router MISSING 2.0.0-rc.2 3.2.3 ionic-conf
erence-app
angular2-text-mask MISSING 2.1.0 2.1.0 ionic-conf
erence-app
body-parser MISSING 1.15.2 1.15.2 ionic-conf
erence-app
cors MISSING 2.8.1 2.8.1 ionic-conf
erence-app
del MISSING 2.2.0 2.2.2 ionic-conf
erence-app
es6-shim MISSING 0.35.0 0.35.1 ionic-conf
erence-app
express MISSING 4.14.0 4.14.0 ionic-conf
erence-app
gulp MISSING 3.9.1 3.9.1 ionic-conf
erence-app
gulp-tslint MISSING 5.0.0 7.0.1 ionic-conf
erence-app
gulp-watch MISSING 4.3.5 4.3.11 ionic-conf
erence-app
ionic-gulp-browserify-typescript MISSING 2.0.0 2.0.0 ionic-conf
erence-app
ionic-gulp-fonts-copy MISSING 1.0.0 1.0.0 ionic-conf
erence-app
ionic-gulp-html-copy MISSING 1.0.0 1.0.0 ionic-conf
erence-app
ionic-gulp-sass-build MISSING 1.0.0 1.0.0 ionic-conf
erence-app
ionic-gulp-scripts-copy MISSING 2.0.1 2.0.1 ionic-conf
erence-app
ionic-gulp-tslint MISSING 1.1.0 1.1.0 ionic-conf
erence-app
ionic-native MISSING 1.3.27 2.2.7 ionic-conf
erence-app
ionic2-input-mask MISSING 0.18.6 0.18.6 ionic-conf
erence-app
ionicons MISSING 3.0.0 3.0.0 ionic-conf
erence-app
pg MISSING 6.1.0 6.1.0 ionic-conf
erence-app
reflect-metadata MISSING 0.1.3 0.1.8 ionic-conf
erence-app
request MISSING 2.79.0 2.79.0 ionic-conf
erence-app
run-sequence MISSING 1.1.5 1.2.2 ionic-conf
erence-app
rxjs MISSING 5.0.0-beta.6 5.0.0-rc.4 ionic-conf
erence-app
tslint MISSING 3.15.1 4.0.2 ionic-conf
erence-app
tslint-ionic-rules MISSING 0.0.5 0.0.8 ionic-conf
erence-app
zone.js MISSING 0.6.12 0.7.2 ionic-conf
erence-app