Update Ionic project

#1

I created an Ionic project about a month ago, and currently am running with these packages:

What/how can I update dependencies without breaking everything? I want to install a package that requires angular 2.3 or above, and I am not sure I should update.

Any relevant article will be appreciated.

BTW:

ordova CLI: 6.4.0
Ionic Framework Version: 2.0.0
Ionic CLI Version: 2.2.1
Ionic App Lib Version: 2.2.0
Ionic App Scripts Version: 1.0.0
ios-deploy version: Not installed
ios-sim version: Not installed
OS: Windows 10
Node Version: v6.9.1
Xcode version: Not installed

#2

Ionic does not support 2.3 yet, so I think you are out of luck at the moment. I have not seen a timeline from them on when they will ‘certify’ an update to Angular.