Getting message : unfortunately, app has stopped on android 4.4 kitkat [not related to ionic]


#1

UPDATE : I have discovered that this issue isn’t specific to ionic. I have no idea how to delete a thread on these forums, I’ll let this thread live till I do find out or any other person deletes it.

I’ve gone through the cordova build process and now I’m trying to run my app on my devices/emulators.

The app is working fine on all other platforms except android 4.4, where it crashes with the message unfortunately, app has stopped.

I’m running windows 7 with cordova 3.4

Help will be greatly appriciated


#2

Hey saw that you found out this wasnt an ionic issue, still I wish to help. When you run your app in the browser, are you getting any errors in you console?


#3

Hey @mhartington. Unfortunately this issue is bigger than all of us. It’s some genymotion emulator glitch or something. I have reported this to genymotion google group, and hopefully this will get resolved there. I have tried other emulators and I’m not experiencing this problem on them.

Thanks for offering help though!


#4

Hi peey I got the same error on KitKat. on 4.0.3 app is working fine… Do you have some link where you report the problem ?

regards,


#5

on KitKat or on a KitKat emulator?

If you’re on the genymotion emulator, try running their browser app, it will close too with the same error message. The issue has been filed here : https://groups.google.com/forum/#!searchin/genymotion-users/Browser$20not$20supported$204.4.2$20version$3F/genymotion-users/v6ryuyHCM_E/r_LzEe_v1-0J be sure to leave a comment so that it gets more attention.


#6

I am having this same problem, but on my phone. I’m using the beta10 and I followed the instructions on http://ionicframework.com/docs/guide/publishing.html. My app is installed, but it can’t be launched and the following message appears: “Unfortunately, APP_NAME has stopped.” And nothing I could do to workaround this issue. Anybody else? I got the Android 4.4.3


#7

@matheuscas make sure that it isn’t a plugin problem, and check if it works on other android versions.


#8

@peey I have only those default plugins: com.ionic.keyboard and org.apache.cordova.device (for production, I had to remove the console plugin). And I just tested in another Android version (4.1.2) and got the same issue (tested on a phone too).


#9

This problem almost drove me nuts. What I finally got to was two things. One, I made sure that all of the files in my project were owned by me, that is, chown -R lannie *. I chmod’d them all 777 too, because I’m sloppy that way. The other thing was, it was messing up when I tried to change the app name from CordovaApp to my app name in platforms/Android. Seems to me I was able to do this in a prior project a few months ago, but not now. What I finally did was let it all build as CordovaApp, and then I changed to my project name for the final step of: sudo /Users/lannie/Downloads/android-sdk-macosx/build-tools/20.0.0/zipalign -v 4 CordovaApp-release-unsigned.apk MY_PROJECT_NAME.apk. Don’t know how much of this was necessary or even wise, but at least the final .apk runs in GenyMotion. Now to submit to the Play store…

Later … this appears to have just been voodoo, I cannot reproduce my results. I am now crazy.


#10

same issue here with windows 8.1 and the latest ionic.

In my case, i started to notice this behavior after i added the source code to github. What i did to solve it was to delete all platforms and build everything again.


#11

Same issue here, not sure where to go from here :frowning:


#12

For me this error was related to the ionic keyboard cordova plugin and having just renamed my app. See Tilo’s answer: http://stackoverflow.com/questions/26383949/cant-run-ionic-on-android-class-not-found-exception-ionickeyboard


#13

Thanks! I wasn’t able to get any trace at all. I just tried the solution you pointed out just in case and it happened to work.

Again, thanks!


#14

I got this error as well, on the actual phones (two phones tested). It was a bug in my SCSS: there were semi colons missing after some SCSS variables, for example:

background: $forecast-bg-color

instead of

background: $forecast-bg-color;

This seemed to be the problem for me! hope it helps someone :>


#15

Reinstalling ionic keyboard also worked for me. Thanks!


#16

In recently updated my android sdk on windows and had this issue. I noticed the first build would install to the device but any attempts after would not. Solution for me
1-delete com.ionic.keyboard from the plugins folder
2- re-install com.ionic.keyboard in same folder
3- delete any ios or android.json files in this folder
4- rebuild
5- ionic run android