Android Emulator only shows "Unfortunately, App has stopped." Error

I am have successfully been able to run the Android emulator and the Genymotion emulator to test my app, however every time the app attempts to launch it starts to open and then I get the error “Unfortunately, App has stopped”.

I get this error in both emulators and have tried a blank ionic project and the blank project opens up fine, so I am convinced it is something within my application build, code, or cordova plugin issue.

My app works fine in the iOS simulator, ionic serve, and in the iOS Ionic View app. My question is how can I troubleshoot what is going wrong with the Android emulator? If I try to open up Chrome Dev Tools and inspect the webview device for the emulator it is not available. And when I goto my Android logcat.txt file I can’t make heads or tails of what is going on in there, so I am stuck.

Thanks for your help.

image

2 Likes

Have the same issue here. Try to run on Nexus 6, Android 6.0, No skin, x86 emulator but have this message: Unfortunately, app has stopped. When runs on device (Redmi Note, Android 5.1.1) – every thing is ok.

Yeah I’m having the same problem with an Ionic 2 Project.

I’ve created a new project, got android sdk set up. I run ionic run android - I get no build errors. But when the app launches It has the App has stopped error.

The same project will run fine on Ios emulator and browser. I thought it might have something to do with avd settings.

That’s good to hear you can get it to run on a device.

I was actually able to get the starter app working by following the solution instructions here:

One of the changes I made was installing this with android sdk manager:
Google Play Services (latest)

After doing this the starter app fired right up.

1 Like

Solved my issue too ! thanks

my solved is config Splashscreen is fixed this problem