Failing to install `ionic-service-core`


#1

I’m getting an error when trying to install ionic-service-core. See below for the error. Any thoughts on what is going wrong?

$ ionic add ionic-service-core

Failed to find the bower component "ionic-service-core".
Are you sure it exists? (CLI v1.5.0)

Your system information:

Cordova CLI: 4.3.0
Gulp version:  CLI version 3.8.11
Gulp local:   Local version 3.8.10
Ionic Version: 1.0.0
Ionic CLI Version: 1.5.0
Ionic App Lib Version: 0.1.0
ios-deploy version: 1.5.0
ios-sim version: 3.1.1
OS: Mac OS X Yosemite
Node Version: v0.12.1
Xcode version: Xcode 6.3.1 Build version 6D1002

#2

I’ve noticed that it happens if you don’t already have bower installed globally. So run

npm install -g bower

then try again.


#3

Tried without luck. Same output happens.


#4

Raised a bug: ionic-cli #458


#5

Maybe also try

$ bower install ionic-service-core --save

#6

@encodedmirko that worked! Thanks.


#7

Hi All,

even after having bower installed i still get the first error?

ANy ideas?


#8

You know what got me? I’m on a work network that blocks access to a bunch of ports, which I think was blocking access to git://. I hopped on a different open network, and the original ionic add commands worked just fine.


#9

Thanks Hanamj! That is a valid point


#10

When I try to install via bower install its missing throw error as

repository ‘https://github.com/fians/Ink.git/’ not found

may be need to replace the dependency.


#11

Yeah i Think about blocked internet. u can Using Hotspot Shield , after activate hotspot shield try again, its work fine.


#12

I had the same error on Ubuntu 14.04. I fix it changing ownner in both .config and .cache directories with this command sudo chown -R [user name] ~/.config and sudo chown -R [user name] ~/.cache hope works for others


#13

modify git protocol

git config --global url."https://".insteadOf git://