Blank screen on emulator and Ionic View


#1

Hello,

I developed an Ionic App using tabs template, and when I use the android emulator, I got a blank screen. Also, this happen when use Ionic View, however works well on iOS emulator.
Any thoughts?

Ionic version: 1.6.4
Cordova version: 5.1.1
Node: 0.12.7 (use nvm)
Mac OS X Yosemite


#2

Have you tried on a real device using Chrome remote debugging via USB port?


#3

I installed the apk in an Android Device (Samsung S4) and same. The blank screen. I haven’t debugging it with Chrome. I will investigate that.


#4

That’s the most important thing you need to do because without it you are blind.


#5

I found the issue, looks like Android doesn’t load the cordova plugins, I need to add it manually. But how about Ionic View, how do I debug that ?

Thanks.


#6

I think Cordova-Android doesn’t make the hooks, I’m using cordova-android@3.6.3 bc the last release send me an error.


#7

Wow that’s very old.

Have you checked that these files exist in the plugin?
Because the first one looks like a remote URL from google rather than a file URL.


#8

Yeah, I missed the “http://”.
I added the latest cordova-android release:

Android project created with cordova-android@4.0.2
Running command: /Users/Ytzvan/zazia/hooks/after_prepare/010_add_platform_class.js /Users/Ytzvan/zazia
add to body class: platform-android
Installing "com.ionic.keyboard" for android
Installing "com.phonegap.plugins.PushPlugin" for android
Installing "com.phonegap.plugins.facebookconnect" for android
Installing "cordova-plugin-inappbrowser" for android
Installing "cordova-plugin-whitelist" for android
Installing "org.apache.cordova.device" for android

But, when I run ionic build android I got the following:

error caught: Error: spawn EACCES
/Users/Ytzvan/zazia/platforms/android/cordova/node_modules/q/q.js:126
                    throw e;

I set execution permisions, chmod, chown and still getting the error.
Any thoughts?


#9

EACCES is usually due to missing execution rights but not sure it is about the file you copied here.

Try rm platform and add it again


#10

Hello, I got the EACCES issue with cordova-android@4.0.2 and newer versions. I installed cordova-android@3.7 and worked fine. The blank screen issue was because ionic don’t registered the modules as Android dependencies.

I re-installed the cordova plugins, with --save flag at the end and everything run fine.

Now it’s running good.

Thanks