Announcing Ionic 4 beta!


#43

I am redoing it. I don’t think there is any easy migration path. And vue.js is so cool so I am doing it in Vue JS.


#44

Which IDE you are using for IONIC 4


#45

ATOM https://atom.io/


#46

Using this IDE, we can built for Both Android & IOS right


#47

Muito bom :sorrindo:


#48

Congratulations and thanks for your great job!


#49

This is my second tutorial about Ionic 4 and Angular 6. You can try follow the step by step easily to feel the new Ionic 4.


#51

I have an issue with ionic lab after updating to ionic cli 4.1.1.
It shows this error in the browser’s console:
“:8200/build/ionlab/ionlab.925lkwi9.js:1 Failed to load resource: the server responded with a status of 404 (Not Found)”

I used this command to create the project:
“ionic start ionictest sidemenu --type=angular”
and this command to start the application:
“ionic serve -l -w=chrome”

I tried cleaning npm cache and reinstalling ionic but didn’t work.
Any one is experiencing the same issue?


#52

Hey, guys!
Great work!
Just migrated from v3 to v4 (including manual installation of all plugin’s and other third-party packages), but got lots of npm WARNs like these:

npm WARN @ionic-native/contacts@4.12.0 requires a peer of @ionic-native/core@^4.11.0 but none is installed. You must install peer dependencies yourself.
npm WARN @ionic-native/contacts@4.12.0 requires a peer of rxjs@^5.5.11 but none is installed. You must install peer dependencies yourself.
npm WARN @ionic-native/email-composer@4.12.0 requires a peer of @ionic-native/core@^4.11.0 but none is installed. You must install peer dependencies yourself.
npm WARN @ionic-native/email-composer@4.12.0 requires a peer of rxjs@^5.5.11 but none is installed. You must install peer dependencies yourself.
npm WARN @ionic-native/local-notifications@4.12.0 requires a peer of @ionic-native/core@^4.11.0 but none is installed. You must install peer dependencies yourself

Seems in v4 native plugins still depend on old rxjs and ionic-native/core?

Thanks!


#53

ionic-native should be upgraded to 5.0.0-beta.14


#54

I’m a bit confused.
If I have

>ionic --version
4.1.1

I think this means that I have Ionic CLI 4.1.1 but not an Ionic 4 app, isn’t it?
Because I created the app with the command: “ionic start tabs mytest”.
To have an Ionic 4 app I have to create it with the command “ionic start myApp tabs --type=angular”.

Is it right?
Downloading an app from the web how can I see if it is a Ionic3 or a Ionic4 app?

thank you

cld


#55

Yes, you have latest CLI and that can only compile and run V4-apps

There are a lot of differences between Ionic 3 and 4. If you have the source just look at the directory structure

src/app

in V4 pages is placed here, but in V3 you have src/pages


#56

Are you sure?
I don’t think so.
I think that the directive “–type=angular” discriminates between an Ionic3 and an Ionic4 application.


#57

I could confirm too, the Ionic CLI v4 handle well Ionic v3 and v4 apps


#58

–type=angular isn’t that just when you create a project

but you might be right, but the V4 CLI failed to compile my app, maybe because I used Lazy-loading allready


#59

I already got “@ionic-native/core”: “5.0.0-beta.14” installed but it says that, for example, latest @ionic-native/contacts@4.12.0 still depends on previous version of @ionic-native/core@^4.11.0 and rxjs@^5.5.11 (in ionic v4 there is a rxjs v6.2.2 is used)


#60

So you mix the native version? I think you can’t do that. If you use core 5beta, then all native libs should use 5beta too


#61

It’s not me. It’s Ionic v4 ) I started new v4 blank app, then manually installed contacts:

$ ionic cordova plugin add cordova-plugin-contacts
$ npm install --save @ionic-native/contacts

as it says here https://beta.ionicframework.com/docs/native/contacts and got package.json containing

    "@ionic-native/contacts": "^4.12.0",
    "@ionic-native/core": "5.0.0-beta.14",

then if you try to npm update you’ll get these dependency warnings that say that almost all @ionic-native/* plugins are not installed because they depend on lower version of @ionic-native/core and are NOT installed


#62

I think it’s kind of a bit on you :wink:

I guess you started a new Ionic v4 project ionic start --type=angular which comes with ionic-native core v5-beta

then you added contacts, but you didn’t specified the you wanted to use beta wrapper too

npm install --save @ionic-native/contacts@beta

or

npm install --save @ionic-native/contacts@5.0.0-beta.14

of course the doc doesn’t display the @beta because well it’s a beta doc for the upcoming official release, so I’m agree, that’s a bit misleading


#63

Hey!
Thanks a lot reedrichards! It finally worked! And you are right, I could not find any mentioning about specifying @5.0.0-beta.14 after any native plugins