Android Simulator


#1

I’m attempting to run the android emulator and the emulator comes up but the application does not run.

I’ve downloaded the latest Android SDK.
I have 3 jdk’s installed but I’m setting the JAVA_HOME to /Library/Java/JavaVirtualMachines/jdk1.7.0_79.jdk/Contents/Home
The command I’m using to run the emulator is.

ionic emulate android --release -c

I’ve attempted to get this to work on other ionic apps with no luck.

The app itself works on the ionic view both android and ios, ios, and the ios simulator

No logs, No Console messages, No errors.

Not sure where to go from here.


#2

Have you tried Genymotion? Its a lot faster then the default android emulator anyway… And then you can test if its the app code or the emulator that is to blame…

Also, have you tried without the --release param? So just:

ionic emulate android

#3

Have you tried on a real android device?
Personally, I almost never use an emulator, I prefer a real device or a browser.
With Chrome remote debugging, the debugging experience is great.


#4

I tried a real device and it launches and shows my splash screen but then nothing. This is actually the reason I wanted to run the emulator so I could figure out what was wrong with my app.

I should mention that it works on web, iOS, and the ionic view in both android and iOS.


#6

The Genymotion simulator works. That’ll be a good fallback. I was able to find the original problem so hopefully the run command will work again on the original device.

Thanks for your help.

My default simulator still doesn’t work, I may open the topic in the Android forum, I’m not sure if it’s related to ionic.


#7

Hi Edmckee,

No worries, glad it did any good :slight_smile: Be aware though, that Genymotion sometimes has a problem with Android version higher than > 4.4… A lot of people are complaining the emulator works slow on android 4.4.4 and above. Although this doesn’t seem to be the case for all developer, i had the same…

Hope you find a way to fix your default android emulator, as that emulator works pretty fast with android 5.0 :stuck_out_tongue:

Another option to debug the default emulator, is watching the logcat… This shows tons of runtime information about the emulator. I had some trouble in the beginning as well, and was able to filter out the problem by watching the logcat.

Good luck