Ionic start "app" tabs > Unfortunately app has stopped


#1

Hi guys,

I have a problem running an Ionic 1 app on Android and can’t figure out what’s the problem. I googled a lot last week, but all ‘solutions’ don’t work for me. It’s really frustrating… I hope you guys could help!

A have an Ionic 1 app, and build and run it earlier with succes. After a few months I wanted to build an updated version of the app and the problems started. I’ve updated my SDK’s etc. but every time my app quits and the device or the emulator says ‘Unfortunately app has stopped’. After trying a lot of ‘solutions’ found on the internet it is still not working.

Tonight I started a new Ionic tabs project. Ionic serve works well and I have no errors in the console. I run ‘cordova run android’, the build was successfull, the app is launched and then the same frustrating message ‘Unfortunately app has stopped’. What am I doing wrong? Please help!

Ciao,
Mark


#2

Good afternoon.

You have the Android SDK installed?


#3

Yes, API 23, 24 and 25 installed with Android SDK Manager.


#4

Have you tried to run with the command:
ionic build android

Before that you have to verify that you created the virtual machine android, so you can check accessing the directory android if you have any doubts about it is just talk.

Once you have done what I said run this command dento of ionic project:
ionic run android


#5

I’m having the same problems with an Ionic 2 App. I just used the starter. The app will run in browser and ios simulator.

When I run android run myApp it will launch the emulator, but then the app just crashes.

I wonder if it has something to do with the android avd not being correctly configured. I don’t know much about devices and system requirements for android. Does anyone know of any resources to tell me what devices, operating systems I should test for?


#6

Hi, already tried that and it didn’t work… I have a AVD with the following settings:

Name: Nexus
Device: Nexus 6 (5.96", 1440 x 2560: 560dpi)
Target: Android 6.0 - API Level 23
CPU/ABI: Intel Atom (x86)

And I have the following tool versions on OS X Sierra:

NPM: 2.15.5
Node: 4.4.5
Java version: 1.8.0_111
Java™ SE Runtime Environment: build 1.8.0_111-b14
Java HotSpot™ 64-Bit Server VM: build 25.111-b14, mixed mode
Cordova: 6.4.0
Ionic: 2.1.0-beta.3

I hope someone can help me figure out what’s the problem!


#7

Fixed it maybe? I hope!


#8

Hello, this was the solution I found for running an Ionic 2 app on the Android Emulator.

In my case, I think was missing a sdk in the android SDK manager.