XCode permissions

After creating an ionic project $ ionic start myApp sidemenu

then adding iOS as a platform $ ionic platform add ios

then building it $ ionic build ios

Everything seems to work fine (apart from having to add sudo to the beginning of the commands).

My problem is when I try and open the XCode project. I get a “you don’t have permissions…” error. If I change the settings and add myself I then get files locked which can not be unlocked errors during XCode start up.

Any problem from a command line point of view that any one knows about?

Hm, are you using the osx yosemite preview or mavericks? Have you updated your version of xcode and the xcode command line tools?

No worries, it seems to have sorted it self out. There might have been an update between then and now…no sure.

I run the commands just like the Getting Started guide and it works with no problems at all.

I’m getting the same problem, It’s happening now on any new project when I run /$ ionic build ios the XXX.xcodeproj file comes locked with no permissions… I think thats happening after the update of OSX Yosemite. Any help to fix this?

Hmm, what version of xcode are you using? Also what version of the xcode command line tools are you using?

Xcode 6.1 , When I type $ gcc -v
Configured with: --prefix=/Applications/Xcode.app/Contents/Developer/usr --with-gxx-include-dir=/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.10.sdk/usr/include/c++/4.2.1
Apple LLVM version 6.0 (clang-600.0.54) (based on LLVM 3.5svn)
Target: x86_64-apple-darwin14.0.0
Thread model: posix
Is that what you are asking? or how I can check the version you ask? Thanks

I have same problem. My xcode version is 6.1 with OS Yosemite.Please guide me if anyone have solution.

I re-did this on a different mac. Got a permission error again.

I fixed it by doing this on the app folder to change permissions:

sudo chown -R <your-username> .

I did this and opened the XCode project and no one permission errors

1 Like

Where are you trying to build the app? Within your home directory or outside of it?

I’ve recently bought a Mac Mini, installed Yosemite and am not having any problems with the Xcode project (even when switching back and forth between Xcode 5 and Xcode 6

I am only building/creating apps within my home folder though

Personnally, I use sudo chown -R <your-username> . everytime right after a build.

1 Like

Thank You, that’s exactly what worked for me with Yosemite