Weird Console.log: 10 error in google plus login using firebase


#1

I am trying to implement google-plus login using firebase in my Ionic3/Angular application for Android/iOS. I am using cordova-plugin-googleplus plugin and ionic-native-google-plus for google plus login for my application.

I followed this tutorial. But, i am getting an weird console.log: 10 error while trying to login in the android device.

I have found an existing issue link for this specific problem. I have tried everything of there but nothing is working for me. It is taking toll on me for 2-3 days.

Can anyone point me out what could be the solution to avoid this weird error?


#2

I had exactly the same issue on Android device only 10 days ago. My problem was that I forgot to build the app with --release. I did comment the issue you linked, https://github.com/EddyVerbruggen/cordova-plugin-googleplus/issues/243, see “peterpeterparker”


#3

Oh, i will need your help man. It is giving me pain for 2-3 days. I did not understand your below part:

BUT, something really important, if you “only” upload your sha-1 from your release store in firebase then you could also only use the login with gmail if you sign your apk, otherwise it just won’t work

ionic cordova build android --prod
-> Ain’t gonna work, only the sha-1 store of your release is uploaded in Firebase

ionic cordova build android --prod --release
-> Hooray

I have the SHA certificate fingerprint from debug.keystore in the firebase android project. Is it creating problem for me?


#4

Oh if you try with the debug certificate probably not the same issue then, sorry

Hope one of the post in the github issue you linked will guide you to your solution


#5

Did you face this problem with your debug certificate?


#6

I didn’t tried with the debug certificate