Upgrading to Angular 6

#1

Howdy,

So was starting a fresh app, figured I would get Angular up to v6 which is easy enough, but I can’t get past the rxjs blocker for the ionic stuff. I had found another post from around a month ago saying something about Ionic 4 would support it, but should I just stick with Angular 5~ version for a fresh install for now to ensure as I build this new bugger out I don’t run into any “gotcha” scenarios until ionic 4 is ready?

Thanks, and sorry if it’s an ignorant question, just now getting back into ionic after a long (year++) hiatus but looking forward to it!

Cheers!

2 Likes
#2

I would also like to know about this. Especially how to migrate to Angular 6 and use Angularfire2 which expects Angular 6.
Thanks.

1 Like
#3

Yes, Angular 5 with Ionic 3. Ionic is always behind Angular, to keep the code base stable.

#4

Use an earlier version of AF2.

#5

Right now, the 3.x haven’t gotten tested with Angular 6. We’re working on getting the 4.0 out the door, which includes the Angular 6 upgrade, as well as other features too. I would suggest staying on 5.x of Angular and other libraries.

2 Likes
Latest official version of Angular that latest Ionic 3 supports
#6

In relation to Ionic 3 and Angular 6, we have just upgraded to angular 6. We are getting an issue when using ionic serve,with live reload. When we make a change to .ts the app refreshed an the code transpiles but we get the following error.

{ Error: [object Object]
    at new BuildError (C:\Users\A631256\source\ap126129-nb-global-mobile-app\node_modules\@ionic\app-scripts\dist\util\errors.js:16:28)
    at ChildProcess.<anonymous> (C:\Users\A631256\source\ap126129-nb-global-mobile-app\node_modules\@ionic\app-scripts\dist\worker-client.js:37:24)
    at emitTwo (events.js:126:13)
    at ChildProcess.emit (events.js:214:7)
    at emit (internal/child_process.js:772:12)
    at _combinedTickCallback (internal/process/next_tick.js:141:11)
    at process._tickCallback (internal/process/next_tick.js:180:9) hasBeenLogged: false, isFatal: false }

Any ideas or pointers as to what this issue could be ?

“ionic”: “^3.20.0”,
@angular/core”: “~6.0.9”,

Many Thanks

#7

There is a post from a dev immediately above yours saying that this is an unsupported combination, so I would either go with Ionic 4 / Angular 6 or Ionic 3 / Angular 5.

1 Like