Angular version update for Ionic 2

#1

I am running into a bug with a chrome extension when using angularfire2. See https://github.com/angular/angularfire2/issues/581#issuecomment-278208045.

It looks like if I want to fix this I have to update to firebase 3.6.8 or later. But that requires me to update some other peer dependencies (ie rxjs and angularfire2). Moving down the line that requires me to have a version of angular that is later than 2.2.1. But ionic-angular is requiring 2.2.1. Is there any plan for ionic-angular to support a later version of angular so I don’t have to deal with this bug?

#2

Actually, try app-scripts 1.0.1.

#3

I’m sorry. This doesn’t work.

#4

According to this commit in the changelog, it should.

UPDATE

I just tried this and my app seems to build and run fine using angular 4.0.0-beta.5

#5

Did you even read my original post? I don’t even know what this has to do with my problem. Nothing in that changelog mentions the bug I refer to. Can you post your package.json so I can see if your app that is working is referencing the same things that I am?

#6

The only blocking bug that I am aware of that had prevented people from using >=2.3 versions of angular was with app-scripts. That commit removed that roadblock. There may be other problems that I am unaware of, but at the moment I have managed to build my app with angular 4.0.0-beta.5 using ionic-app-scripts 1.0.1. That was previously not possible. Perhaps this will also allow you to upgrade angular versions to the point where it solves your other problems.

1 Like