The AppFlow livedeploy overwrites my tests on the Emulator and on my connected device

Hello dears,
6 months ago I am with the APP in production and using the automatic Deploy and it works very well!
But a whole day ago I’m stuck with a problem and I can not solve it.
I am working on some add-ons for the APP and one of the improvements requires access to the mobile camera.
To verify the operation I connect the PC to the phone with android and I also use an emulator (from the Android Studio). But in both ways the same problem occurs.
The problem is that it automatically deploys the latest version (1.0.5) to the Emulator or Phone and overwrites my new version, so I can not prove the new since the old always appears. The new version is 1.0.6.
I even tried to erase the cordova-plugin.ionic lines from the config.xml. I tried to put
I tried to upload the version to test the AppFlow platform in the Master channel and in package.json the “CHANNEL_NAME” changed it by Master in that way to have the two equal, but it did not work.

Thank you!

  "cordova-plugin-ionic": {
    "APP_ID": "XXXXXX",
    "CHANNEL_NAME": "Master",
    "UPDATE_METHOD": "auto",
    "WARN_DEBUG": "false",
    "UPDATE_API": "https://api.ionicjs.com",
    "MAX_STORE": "2"
  }

<plugin name = "cordova-plugin-ionic" spec = "4.1.7">
    <variable name = "APP_ID" value = "XXXXXX" />
    <variable name = "CHANNEL_NAME" value = "Master" />
    <variable name = "UPDATE_METHOD" value = "auto" />
    <variable name = "WARN_DEBUG" value = "false" />
    <variable name = "UPDATE_API" value = "https://api.ionicjs.com" />
    <variable name = "MAX_STORE" value = "2" />
    <preference name = "DisableDeploy" value = "true" />
</ plugin>

Hi @Emiliano74 …!!

I’m facing the same problem right now. Did you find any solution?

Thanks and best regards.

Hi! @sosa_johan , I dont remember exactly , but I the main problem (i think) was the version of cordova-plugin-ionic, I upgraded to the last and then the property “DisableDeploy” works!
Was very frustrating for the lost time, but I did!
I hope you find fast the solution!

Thank you so much @Emiliano74 …!!! I didn’t notice there was a property named “DisableDeploy”… now it works like a charm :+1:

Thank you again… save my day :smiley:

I am glad to help you @sosa_johan !
GREAT!

Do you by any chance know how to get “DisableDeploy” working on version 5.4.4 of cordova-plugin-ionic? I set the values in the plugin.xml for android to <preference name="DisableDeploy" value="true"/> and it did not work.

Any ideas?