[Stencil][SOLVED] Stencil npm install fsevents 404 not found

I have just following the Getting Started from StencilJS

git clone https://github.com/ionic-team/stencil-app-starter my-app
cd my-app
git remote rm origin
npm install

And I noticed following error during the installation

node-pre-gyp ERR! Tried to download(404): https://fsevents-binaries.s3-us-west-2.amazonaws.com/v1.1.2/fse-v1.1.2-node-v59-darwin-x64.tar.gz
node-pre-gyp ERR! Pre-built binaries not found for fsevents@1.1.2 and node@9.3.0 (node-v59 ABI) (falling back to source compile with node-gyp)

Anyone knows if it’s normal or should it be reported or do that only happens on my laptop and therefore there is maybe a fix?

Thx in advance for the help

Don’t know if it’s linked but yesterday there was a critical incident at npmjs respectively many packages were deleted. Also it seems the packages were restored.

I still face this 404 error, most probably not related actually.

Beginning at 18:36 GMT today, 106 packages were made unavailable from the registry. 97 of them were restored immediately. Unfortunately, people published over 9 of them, causing delays in the restoration of those 9. We are continuing to clean up the overpublications. All installations that depend on the 106 packages should now be working.

Source:

https://status.npmjs.org/incidents/41zfb8qpvrdj

Ok so the problem is the following, I think:

To fix this problem, related to fsevents compatibility with node v9, it requires fsevents@1.1.3
Since one of the library is still requiring fsevents@1.1.2, I face this issue

This is solved in the ionic-pwa-toolkit project, I guess other project like stencil-app-starter gonna be updated soon too. Therefore I close this issue.