Error on installing ionic latest release RC4


#1

Hi,

I am trying to install the latest ionic version and getting errors on installation. My current node version 6.9.1 and npm version is 3.10.3. Please advice on how to resolve the issue.

C:\Users\USER>npm install -g ionic@latest
C:\Users\USER\AppData\Roaming\npm\ionic -> C:\Users\USER\AppData\Roaming\npm\nod
e_modules\ionic\bin\ionic

> fsevents@1.0.15 install C:\Users\USER\AppData\Roaming\npm\node_modules\ionic\n
ode_modules\ionic-app-lib\node_modules\glob-watcher\node_modules\chokidar\node_m
odules\fsevents
> node-pre-gyp install --fallback-to-build

node-pre-gyp ERR! Tried to download: https://fsevents-binaries.s3-us-west-2.amaz
onaws.com/v1.0.15/fse-v1.0.15-node-v48-win32-x64.tar.gz
node-pre-gyp ERR! Pre-built binaries not found for fsevents@1.0.15 and node@6.9.
1 (node-v48 ABI) (falling back to source compile with node-gyp)
Traceback (most recent call last):
  File "C:\Users\USER\AppData\Roaming\npm\node_modules\node-gyp\gyp\gyp_main.py"
, line 16, in <module>
    sys.exit(gyp.script_main())
  File "C:\Users\USER\AppData\Roaming\npm\node_modules\node-gyp\gyp\pylib\gyp\__
init__.py", line 545, in script_main
    return main(sys.argv[1:])
  File "C:\Users\USER\AppData\Roaming\npm\node_modules\node-gyp\gyp\pylib\gyp\__
init__.py", line 538, in main
    return gyp_main(args)
  File "C:\Users\USER\AppData\Roaming\npm\node_modules\node-gyp\gyp\pylib\gyp\__
init__.py", line 523, in gyp_main
    generator.GenerateOutput(flat_list, targets, data, params)
  File "C:\Users\USER\AppData\Roaming\npm\node_modules\node-gyp\gyp\pylib\gyp\ge
nerator\msvs.py", line 2003, in GenerateOutput
    sln_projects, project_objects, flat=msvs_version.FlatSolution())
  File "C:\Users\USER\AppData\Roaming\npm\node_modules\node-gyp\gyp\pylib\gyp\ge
nerator\msvs.py", line 1762, in _GatherSolutionFolders
    return _DictsToFolders('', root, flat)
  File "C:\Users\USER\AppData\Roaming\npm\node_modules\node-gyp\gyp\pylib\gyp\ge
nerator\msvs.py", line 1715, in _DictsToFolders
    for folder, contents in bucket.iteritems():
AttributeError: 'MSVSProject' object has no attribute 'iteritems'
gyp ERR! configure error
gyp ERR! stack Error: `gyp` failed with exit code: 1
gyp ERR! stack     at ChildProcess.onCpExit (C:\Users\USER\AppData\Roaming\npm\n
ode_modules\node-gyp\lib\configure.js:305:16)
gyp ERR! stack     at emitTwo (events.js:106:13)
gyp ERR! stack     at ChildProcess.emit (events.js:191:7)
gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_proces
s.js:215:12)
gyp ERR! System Windows_NT 6.2.9200
gyp ERR! command "C:\\Program Files\\nodejs\\node.exe" "C:\\Users\\USER\\AppData
\\Roaming\\npm\\node_modules\\node-gyp\\bin\\node-gyp.js" "configure" "--fallbac
k-to-build" "--module=C:\\Users\\USER\\AppData\\Roaming\\npm\\node_modules\\ioni
c\\node_modules\\ionic-app-lib\\node_modules\\glob-watcher\\node_modules\\chokid
ar\\node_modules\\fsevents\\lib\\binding\\Release\\node-v48-win32-x64\\fse.node"
 "--module_name=fse" "--module_path=C:\\Users\\USER\\AppData\\Roaming\\npm\\node
_modules\\ionic\\node_modules\\ionic-app-lib\\node_modules\\glob-watcher\\node_m
odules\\chokidar\\node_modules\\fsevents\\lib\\binding\\Release\\node-v48-win32-
x64" "--python=C:/Users/Administrator/.windows-build-tools/python27/python"
gyp ERR! cwd C:\Users\USER\AppData\Roaming\npm\node_modules\ionic\node_modules\i
onic-app-lib\node_modules\glob-watcher\node_modules\chokidar\node_modules\fseven
ts
gyp ERR! node -v v6.9.1
gyp ERR! node-gyp -v v3.4.0
gyp ERR! not ok
node-pre-gyp ERR! build error
node-pre-gyp ERR! stack Error: Failed to execute 'C:\Program Files\nodejs\node.e
xe C:\Users\USER\AppData\Roaming\npm\node_modules\node-gyp\bin\node-gyp.js confi
gure --fallback-to-build --module=C:\Users\USER\AppData\Roaming\npm\node_modules
\ionic\node_modules\ionic-app-lib\node_modules\glob-watcher\node_modules\chokida
r\node_modules\fsevents\lib\binding\Release\node-v48-win32-x64\fse.node --module
_name=fse --module_path=C:\Users\USER\AppData\Roaming\npm\node_modules\ionic\nod
e_modules\ionic-app-lib\node_modules\glob-watcher\node_modules\chokidar\node_mod
ules\fsevents\lib\binding\Release\node-v48-win32-x64 --python=C:/Users/Administr
ator/.windows-build-tools/python27/python' (1)
node-pre-gyp ERR! stack     at ChildProcess.<anonymous> (C:\Users\USER\AppData\R
oaming\npm\node_modules\ionic\node_modules\ionic-app-lib\node_modules\glob-watch
er\node_modules\chokidar\node_modules\fsevents\node_modules\node-pre-gyp\lib\uti
l\compile.js:83:29)
node-pre-gyp ERR! stack     at emitTwo (events.js:106:13)
node-pre-gyp ERR! stack     at ChildProcess.emit (events.js:191:7)
node-pre-gyp ERR! stack     at maybeClose (internal/child_process.js:877:16)
node-pre-gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/chi
ld_process.js:226:5)
node-pre-gyp ERR! System Windows_NT 6.2.9200
node-pre-gyp ERR! command "C:\\Program Files\\nodejs\\node.exe" "C:\\Users\\USER
\\AppData\\Roaming\\npm\\node_modules\\ionic\\node_modules\\ionic-app-lib\\node_
modules\\glob-watcher\\node_modules\\chokidar\\node_modules\\fsevents\\node_modu
les\\node-pre-gyp\\bin\\node-pre-gyp" "install" "--fallback-to-build"
node-pre-gyp ERR! cwd C:\Users\USER\AppData\Roaming\npm\node_modules\ionic\node_
modules\ionic-app-lib\node_modules\glob-watcher\node_modules\chokidar\node_modul
es\fsevents
node-pre-gyp ERR! node -v v6.9.1
node-pre-gyp ERR! node-pre-gyp -v v0.6.29
node-pre-gyp ERR! not ok
Failed to execute 'C:\Program Files\nodejs\node.exe C:\Users\USER\AppData\Roamin
g\npm\node_modules\node-gyp\bin\node-gyp.js configure --fallback-to-build --modu
le=C:\Users\USER\AppData\Roaming\npm\node_modules\ionic\node_modules\ionic-app-l
ib\node_modules\glob-watcher\node_modules\chokidar\node_modules\fsevents\lib\bin
ding\Release\node-v48-win32-x64\fse.node --module_name=fse --module_path=C:\User
s\USER\AppData\Roaming\npm\node_modules\ionic\node_modules\ionic-app-lib\node_mo
dules\glob-watcher\node_modules\chokidar\node_modules\fsevents\lib\binding\Relea
se\node-v48-win32-x64 --python=C:/Users/Administrator/.windows-build-tools/pytho
n27/python' (1)
npm WARN install:fsevents@1.0.15 fsevents@1.0.15 install: `node-pre-gyp install
--fallback-to-build`
npm WARN install:fsevents@1.0.15 Exit status 1
C:\Users\USER\AppData\Roaming\npm
`-- ionic@2.1.17

#2

try installing the latest npm version because it looks like node is no longer in your environment variables and try again


#3

Thank you so much… That works :slight_smile:


#4

No problem always happy to help :slight_smile:
Have a great day