[Solved] Error update

I was update ionic and get the error below:

sudo npm install -g ionic@latest
/usr/local/bin/ionic -> /usr/local/lib/node_modules/ionic/bin/ionic

> fsevents@1.1.2 install /usr/local/lib/node_modules/ionic/node_modules/fsevents
> node install

node-pre-gyp ERR! Tried to download(undefined): https://fsevents-binaries.s3-us-west-2.amazonaws.com/v1.1.2/fse-v1.1.2-node-v51-darwin-x64.tar.gz 
node-pre-gyp ERR! Pre-built binaries not found for fsevents@1.1.2 and node@7.4.0 (node-v51 ABI) (falling back to source compile with node-gyp) 
gyp ERR! clean error 
gyp ERR! stack Error: EACCES: permission denied, rmdir 'build'
gyp ERR! System Darwin 16.7.0
gyp ERR! command "/usr/local/bin/node" "/usr/local/lib/node_modules/node-gyp/bin/node-gyp.js" "clean"
gyp ERR! cwd /usr/local/lib/node_modules/ionic/node_modules/fsevents
gyp ERR! node -v v7.4.0
gyp ERR! node-gyp -v v3.6.2
gyp ERR! not ok 

  1. Don’t use sudo.
  2. Install nvm.
  3. Use nvm to install the latest Node from track 6, 7, or 8.
  4. Once you have that, install Ionic.

Thank you @AaronSterling
but… what is nvm?

Node version manager.

1 Like

Ok. I installed nvm, updated node and ionic, and now I got the warning below:

npm install -g cordova-check-plugins
npm WARN deprecated node-uuid@1.4.8: Use uuid module instead
npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated node-uuid@1.4.7: Use uuid module instead

is there related ?

libMobileGestalt MobileGestalt.c:550: no access to InverseDeviceID

and when app runs, after splash screen a blank page appears.

the command npm install -g uuid just update uuid, but no changes.

I commented all the code in home.ts ( maybe a plugin is trying to do something before the platform read?) but no success…

and when I create a new project, all works.

Ignore the warnings. That’s a problem of cordova-check-plugins, but nothing critical.

Did you remote debug the problem on the device already?
Follow these instructions here to debug the problem in Safari dev tools: Remote Debug your Ionic App · ionic.zone
Follow these instructions here to debug the problem in Chrome dev tools: Remote Debug your Ionic App · ionic.zone
Look at the console and network tabs for errors.

1 Like

Thank you @Sujan12… that’s it… I needed inserted a import for httpmodule in app.modules.ts


thank you

1 Like