Problem with ios build


#1

Most of the time ionic run ios gets stuck in the middle of the build process without any errors. ionic serve and ionic serve --lab both work just fine everytime. It also happens exactly the same with a fresh install of a blank template.

It always happens at the same point.

Build settings from configuration file '/Users/jrwhip/Documents/projects/ShareXimo/platforms/ios/cordova/build-debug.xcconfig':
CLANG_ALLOW_NON_MODULAR_INCLUDES_IN_FRAMEWORK_MODULES = YES
CODE_SIGN_IDENTITY = iPhone Developer
ENABLE_BITCODE = NO
GCC_PREPROCESSOR_DEFINITIONS = DEBUG=1
HEADER_SEARCH_PATHS = "$(TARGET_BUILD_DIR)/usr/local/lib/include" "$(OBJROOT)/UninstalledProducts/include" "$(OBJROOT)/UninstalledProducts/$(PLATFORM_NAME)/include" "$(BUILT_PRODUCTS_DIR)"
IPHONEOS_DEPLOYMENT_TARGET = 8.0
OTHER_LDFLAGS = -ObjC
SWIFT_OBJC_BRIDGING_HEADER = $(PROJECT_DIR)/$(PROJECT_NAME)/Bridging-Header.h
TARGETED_DEVICE_FAMILY = 1,2

I have tried upgrading the Ionic CLI, Cordova, as well as reinstalling Xcode, but the problem has always been the same.

Currently I have this configuration:

Cordova CLI: 6.4.0
Gulp version:  CLI version 1.2.1
Gulp local:  
Ionic Framework Version: 2.0.0-rc.1
Ionic CLI Version: 2.1.4
Ionic App Lib Version: 2.1.2
Ionic App Scripts Version: 0.0.36
ios-deploy version: 1.9.0 
ios-sim version: 5.0.8 
OS: Mac OS X Sierra
Node Version: v6.6.0
Xcode version: Xcode 8.1 Build version 8B62

Any idea why this may be happening?


#2

Same problem here with ionic 1. After upgrading to Xcode 8.1 builds don’t work anymore. Have the feeling this is due to Xcodebuild in 8.1. Will downgrade to 8.0 and see if that solves the problem.


#3

Xcode 8 gave the same problem, but then I noticed I recently switched to iCloud documents and my documents folder contained all my code. Moving my development folder out of Documents fixed it for me. Apparently iCloud sync interferes with the build process.


#4

I am having the same error on the new xCode 10, sadly my file isn’t in iCloud folder

 ionic (Ionic CLI)  : 4.5.0 (/usr/local/lib/node_modules/ionic)
   Ionic Framework    : ionic-angular 3.9.2
   @ionic/app-scripts : 3.2.0

Cordova:

   cordova (Cordova CLI) : 8.1.2 (cordova-lib@8.1.1)
   Cordova Platforms     : android 7.0.0, ios 4.5.5
   Cordova Plugins       : cordova-plugin-ionic-keyboard 2.1.3, cordova-plugin-ionic-webview 2.2.0, (and 5 other plugins)

System:

   NodeJS : v10.14.0 (/Users/guifeliper/.nvm/versions/node/v10.14.0/bin/node)
   npm    : 6.4.1
   OS     : macOS Mojave
   Xcode  : Xcode 10.1 Build version 10B61