Unable to build iOS on Ionic 2

Hi there,

Recently updated to Sierra and also update Ionic CLI 2.1.0 and the iOS build stopped working. When I run ionic build ios, it gets stuck (see screenshot below)

Tried removing ios platform and re-adding it. Doesn’t seem to work.

Any help will be much appreciated.

Your system information:

Cordova CLI: 6.3.1
Ionic Framework Version: 2.0.0-beta.11
Ionic CLI Version: 2.1.0
Ionic App Lib Version: 2.1.0-beta.1
ios-deploy version: 1.8.5
ios-sim version: 5.0.6
OS: Mac OS X El Capitan
Node Version: v4.3.0
Xcode version: Xcode 8.0 Build version 8A218a

Have you launched Xcode directly? There are often additional T&Cs that need to be agreed to that ‘break’ the build chain.

Chris

Hi @ChrisGriiffith, thanks for replying. Yes, I’ve launched Xcode and everything seems to be fine on the Xcode side. It’s just doesn’t build on ionic for iOS. Building on Android seems to work fine.

Wasn’t able to figure it out in the end. Previous attempt didn’t quite fix it. Seems to be inconsistent the result. Works earlier, but gets stuck again after another build attempt.