[Partially Solved] I'm getting the "blank page error" after splashscreen

The application works correctly with ionic:serve when testing locally, but when I get the APK installed on my device then it shows the splash screen and then just a blank page.

The problem seems to be caused by typescritp@2.9.x, I don’t really know the reason but I’ve tried with v2.8.4 and it works as expected.

Do you guys have more information about this? have you experimented this error? Might it be related to my project configuration?

when you debug on device, there is no message?

I’m sorry, I don’t really know how debug on device works. I tried listening on the system log with adb but didn’t get anything interesting.

On chrome, go to chrome//inspect, select your app. You must launch with ionic cordova run android -l to get livereload

What Ionic version are you using? If the answer is 3, then you’ve basically answered your own question. Do not upgrade TypeScript past the version that Ionic proclaims compatibility with. TypeScript 2.9 will work with Ionic v4, but not v3.

1 Like