Old version of my app builds rather than latest?

The strangest thing!

If I run ionic serve --lab it displays the latest version from my www folder (updated controllers, HTML, CSS, etc).

When I run ionic build ios and then ionic emulate ios it runs an old version of my app from a few days ago which is extremely different to my current.

I’ve done an ionic state reset, ionic platform remove ios and ionic platform add ios with no luck.

Has any one else experienced this before? (aside from @jacobscarter here where there was no solution.
Any idea what else I can run to get it building cleanly?

Thank you.

1 Like


I realised that after changing the bundle ID it was installing a second version of the app in Simulator.

  1. I first deleted Xcode derived data by doing a sudo rm -rf ~/Library/Developer/Xcode/DerivedData/*
  2. Then I fired up the project in Xcode and did Shift-Cmd-K to clean the build.
  3. Finally, within Simulator, I minimised the app and deleted the app from Simulator’s home screen.