Ionic cordova run/build ios --prod not updating

This is really strange. First I have seen this problem iOS build not updating with Xcode and “ionic run ios --prod” , code is not updating and I have tried whatever they have suggested in those links but to no avail. Things that I have tried so far are.

  • Remove the iOS platform and add again
  • Delete www folder
  • Restart both phone and my Mac Mini
  • Update Cordova to the latest as shown in my ionic info below.
  • Using ionic cordova run ios --prod and installing using Xcode
  • Deleted or Uninstall the app from iPhone 6 plus.

Some of the pages that the app deploys and displays are all deleted, so I am convinced that the command is not updating or installing the latest build.

Below you will find my ionic info.

@ionic/cli-utils  : 1.19.1
ionic (Ionic CLI) : 3.19.1

global packages:

cordova (Cordova CLI) : 8.0.0 

local packages:

@ionic/app-scripts : 3.1.4
Cordova Platforms  : ios 4.5.4
Ionic Framework    : ionic-angular 3.5.3

System:

ios-deploy : 1.9.2 
ios-sim    : 6.0.0 
Node       : v8.9.4
npm        : 5.6.0 
OS         : macOS High Sierra
Xcode      : Xcode 9.2 Build version 9C40b 

Misc:

backend : pro

Do you use ionic deploy?

No I am not using Ionic Deploy.

What exactly is happening? are some sites not availible or is there an error or sth like that?
Your problem seems weird.

You are right this is really weird. I am not getting any error. First compilation and running works fine but then after closing the app and opening it again it displays the old version. I almost pulled all my hair off!

:face_with_raised_eyebrow:

Is there some chaching going on? somewhere? The nearest possibility that I can think of is some plugin like ionic deploy that resets the app files…

How do you can tell the differences between new and old? Try changing some header/ or other colors to make sure it’s really the old version. Then search in the folders for a string/file only your old version had and find the place where it’s hiding…

Thanks, I have totally change the landing page of the app. So I can vehemently confirm that it is loading a different version. How can I check if ionic deploy may be the problem? I can also confirm that this issue does not exist on Android.

You are right! The culprit is ionic deploy. I last updated the ionic branch couple of weeks ago and my app is updated to that version after closing and opening it. Does this makes sense to you. Can you shed more light on ionic deploy?

https://ionicframework.com/docs/pro/deploy/

Ionic pro deploy is useful for providing your audience with hotfixes that bypass the store update methodes.
(It replaces your www files with the one that are on the server)