Npm WARN optional SKIPPING OPTIONAL DEPENDENCY

#1

When I’m trying to install the ionic native plugin

npm install --save @ionic-native/linkedin

I’m getting some error messages in my command prompt as

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.0.0 (node_modules\chokidar\node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.1.2 (node_modules\watchpack\node_modules\chokidar\node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})
npm WARN @angular/platform-server@2.4.10 requires a peer of @angular/core@2.4.10 but none was installed.
npm WARN @angular/platform-server@2.4.10 requires a peer of @angular/common@2.4.10 but none was installed.
npm WARN @angular/platform-server@2.4.10 requires a peer of @angular/compiler@2.4.10 but none was installed.
npm WARN @angular/platform-server@2.4.10 requires a peer of @angular/platform-browser@2.4.10 but none was installed.
npm WARN @angular/router@3.4.10 requires a peer of @angular/core@2.4.10 but none was installed.
npm WARN @angular/router@3.4.10 requires a peer of @angular/common@2.4.10 but none was installed.
npm WARN @angular/router@3.4.10 requires a peer of @angular/platform-browser@2.4.10 but none was installed.
npm WARN bootstrap@4.1.1 requires a peer of jquery@1.9.1 - 3 but none was installed.
npm WARN bootstrap@4.1.1 requires a peer of popper.js@^1.14.3 but none was installed.
npm WARN @angular/compiler-cli@5.0.0 requires a peer of typescript@>=2.4.2 <2.5 but none was installed.
npm WARN tsickle@0.24.1 requires a peer of typescript@2.4.2 but none was installed.
npm WARN ionic2-auto-complete@1.6.2-alpha requires a peer of @angular/core@^4.0.0 but none was installed.
npm WARN @angular/core@2.4.10 requires a peer of zone.js@^0.7.2 but none was installed.
npm WARN @angular/platform-browser-dynamic@2.4.10 requires a peer of @angular/compiler@2.4.10 but none was installed.
npm WARN ngx-bootstrap@3.0.0 requires a peer of @angular/common@>=6.0.0 but none was installed.
npm WARN ngx-bootstrap@3.0.0 requires a peer of @angular/core@>=6.0.0 but none was installed.
npm WARN ngx-bootstrap@3.0.0 requires a peer of @angular/forms@6.0.1 but none was installed.
npm WARN react-native-card-stack-swiper@1.0.8 requires a peer of react@^16.0.0-beta.5 but none was installed.
npm WARN react-native-card-stack-swiper@1.0.8 requires a peer of react-native@^0.49.1 but none was installed.

How can I resolve this?

#2

It looks like you are attempting to bolt ionic onto a non-ionic project. The v4 beta just came out yesterday, you might want to look into using that, but I think it’s pretty hopeless to try this strategy with any earlier ionic versions.

#3

I am having a similar problem:

npm WARN @ionic/ng-toolkit@1.0.0 requires a peer of @angular-devkit/architect@0.7.0-rc.1 but none is installed. You must install peer dependencies yourself. plus 5 further warnings.

All I did was to start a new Ionic project, generate a service and then run:
npm install pouchdb @types/pouchdb --save

Any ideas?

Edit: Further searching brought this up:

I didn’t really update any packages so in my case I am surprised to have any warnings at all.