Ionic 3 dependency error: You must install peer dependencies yourself


#1

I am having this issue when I am trying to install camera plugin…

npm WARN @angular/platform-server@4.0.2 requires a peer of @angular/animations@4.0.2 but none is installed. You must install peer dependencies yourself.
npm WARN @angular/platform-server@4.0.2 requires a peer of @angular/core@4.0.2 but none is installed. You must install peer dependencies yourself.
npm WARN @angular/platform-server@4.0.2 requires a peer of @angular/common@4.0.2 but none is installed. You must install peer dependencies yourself.
npm WARN @angular/platform-server@4.0.2 requires a peer of @angular/compiler@4.0.2 but none is installed. You must install peer dependencies yourself.
npm WARN @angular/platform-server@4.0.2 requires a peer of @angular/platform-browser@4.0.2 but none is installed. You must install peer dependencies yourself.
npm WARN @ionic-native/splash-screen@3.4.2 requires a peer of @ionic-native/core@^3.1.0 but none is installed. You must install peer dependencies yourself.
npm WARN @ionic-native/status-bar@3.4.2 requires a peer of @ionic-native/core@^3.1.0 but none is installed. You must install peer dependencies yourself.
npm WARN @ionic/cli-plugin-ionic-angular@1.3.1 requires a peer of @ionic/app-scripts@^1.3.7 but none is installed. You must install peer dependencies yourself.
npm WARN angular2-google-maps@0.17.0 requires a peer of @angular/common@^2.3.1 but none is installed. You must install peer dependencies yourself.
npm WARN angular2-google-maps@0.17.0 requires a peer of @angular/core@^2.3.1 but none is installed. You must install peer dependencies yourself.
npm WARN ionic-gallery-modal@0.2.7 requires a peer of @angular/core@^4.1.3 but none is installed. You must install peer dependencies yourself.
npm WARN ionic-gallery-modal@0.2.7 requires a peer of ionic-angular@3.6.0 but none is installed. You must install peer dependencies yourself.
npm WARN ionic-gallery-modal@0.2.7 requires a peer of rxjs@^5.4.2 but none is installed. You must install peer dependencies yourself.
npm WARN ionic-img-viewer@2.7.3 requires a peer of ionic-angular@3.7.1 but none is installed. You must install peer dependencies yourself.
npm WARN uglifyjs-webpack-plugin@0.4.6 requires a peer of webpack@^1.9 || ^2 || ^2.1.0-beta || ^2.2.0-rc || ^3.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.1.2 (node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.2: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})`Preformatted text`

#2

look at npm list or your package.json file

you will see your plugin versions. every plugin is compatible with specific versions of other plugins and they have to go together. (if there is ‘^4.0.3’ for example, it will update to 4.0.5 (if available) and probably won’t fit to sopme dependencies)

tipp: look the Output you posted already, it tells you exactelly what you Need and always use --save to install npm plugins. else it doesn’t save the plugin toi your package.json and it’s missing again, if you pull it from github for example.