Cant update ionic native


#1

I have a problem with updating native/core to current version. Every time i run npm install, there is couple of errors :

C:\angular\dochazkamobilni>npm install
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.0.0 (node_modules\chokidar\node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.2: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})
npm WARN @ionic-native/native-storage@3.14.0 requires a peer of @ionic-native/core@^3.6.0 but none was installed.
npm WARN @ionic-native/network@3.14.0 requires a peer of @ionic-native/core@^3.6.0 but none was installed.
npm WARN @ionic-native/sim@3.14.0 requires a peer of @ionic-native/core@^3.6.0 but none was installed.
npm WARN @ionic-native/splash-screen@3.4.2 requires a peer of @ionic-native/core@^3.1.0 but none was installed.
npm WARN @ionic-native/sqlite@3.14.0 requires a peer of @ionic-native/core@^3.6.0 but none was installed.
npm WARN @ionic-native/status-bar@3.4.2 requires a peer of @ionic-native/core@^3.1.0 but none was installed.

i tried npm install @ionic-native/core@4.3.2 --save, i tried unistall native/core and install again, but these warnings wont go away. Any ideas?


#2

try sudo npm install


#3

These are only warnings, nothing that indicates that something didn’t work.
The warnings indicate a version mismatch though.

What is your package.json content?
What is your ionic info output?


#4

Please don’t do this.

It sounds to me like you just need to update the various plugins you have installed to the latest version as well. @Sujan12 is right though that there aren’t any errors here.


#5

Its ok, i fixed it by updating plugins to actual versions. Is there any way, that i can update all plugins at once? So i dont have to update them one by obe?