Network Error when testing on device with livereload

This is a case I’ve NEVER seen before, and I’m totally stuck!
I run ionic cordova run android -lc as usual to test it on my device (Samsung Galaxy S4) and get

Application Error
There was a network error (http://localhost:8100/)

Chrome debug just has the following line…

Failed to load resource: the server responded with a status of 404 (Not Found)

This is normal if there’s no Wifi connection, but I’ve confirmed that the connection works fine. I tried on an iPhone and just got a blank screen, with some network-connection-related issues appearing in the log.
If I navigate to localhost:8100 on my browser on the computer, it works.

I even removed and readded teh Android platform and the iOS platform, still the same issue, and config.xml has
<allow-navigation href="*" />

If I run it without livereload, it works fine, but I won’t be able to debug it!

Please help!! This is really urgent and the app is facing launch delays till this is resolved!
Thanks.

Resolved by reinstalling cordova-plugin-whitelist. Not sure why it had to be reinstalled, but alas it works now.