Job failed create_capacitor_config

Hi, I have an issue when compiling with the Appflow tool. It gives me the following error:

Shell command exited with exit status 126 instead of 0.
sh: 1: cap: Permission denied
unexpected token at 'sh: 1: cap: Permission denied

The thing is, I’ve only made a change in one of the Vue files, I haven’t updated anything or changed any other data. In fact, I’ve tried compiling a commit from a few days ago (03/11/2023) that worked perfectly, and now it’s giving me the same error.
When searching online, it always refers to a permissions issue, which I logically can’t change.
Thank you very much for your help.

1 Like

For anyone that have the same problem,
There is one change during the dependency install. Instead of:
npm ci --omit=optional --quiet
We are now seeing:
npm install --omit=optional --quiet
So this could be causing the dependencies to be installed differently, which could explain the differences in the builds.
So it’s posibly to modify your dependency install command, this can be done with an appflow.config.json:

Another option it’s to add .gitignore and make sure that node modules are not being committed