Appflow with capacitor detects cordova instead

Hi, I’ve recently added capacitor to my Vue project, i’m not using Cordova and have enabled capacitor in the appflow project. However when i try to build, it always throw error because appflow is detecting it as a Cordova project and trying to look for ‘www’ webDir which I didn’t config anywhere in my code… I’m using workspaces in my repo and my project is under /package/, the ionic.config.json is living under /package/myApp. I’m guessing if that will be the reason why it’s not getting the config properly? Any thoughts and suggestions would be greatly appreciated!

Cloning into '/builds/account-name/repo-name'...
Cloning repository...
Checking out 25d87ac4 as commit-msg...
Updating/initializing submodules...
$ run "fetch-updates"
$ run "build-app"
[20:58:16]: ------------------------------
[20:58:16]: --- Step: default_platform ---
[20:58:16]: ------------------------------
[20:58:16]: Driving the lane 'android deploy_build' 🚀
[20:58:18]: ---------------------------
[20:58:18]: --- Step: build_summary ---
[20:58:18]: ---------------------------

+---------------------+---------------------------+
|                  Build Summary                  |
+---------------------+---------------------------+
| Job ID              | 6974319                   |
| Node.js version     | v12.17.0                  |
| Cordova CLI version | 9.0.3 (cordova-lib@9.0.2) |
| npm version         | 6.14.4                    |
+---------------------+---------------------------+

[20:58:18]: ---------------------------------
[20:58:18]: --- Step: add_git_credentials ---
[20:58:18]: ---------------------------------
[20:58:18]: Writing git-credentials files
[20:58:18]: git-credentials successfully added to project
[20:58:18]: --------------------------------
[20:58:18]: --- Step: detect_native_type ---
[20:58:18]: --------------------------------
[20:58:18]: Checking if cordova or capacitor project
[20:58:18]: Cordova project detected
[20:58:18]: -------------------------
[20:58:18]: --- Step: get_web_dir ---
[20:58:18]: -------------------------
[20:58:18]: webDir is `www`
[20:58:18]: -------------------------------
[20:58:18]: --- Step: modify_config_xml ---
[20:58:18]: -------------------------------
[20:58:18]: No custom native config detected.
[20:58:18]: ---------------------------
[20:58:18]: --- Step: build_pro_app ---
[20:58:18]: ---------------------------
[20:58:18]: Installing Dependencies
[20:58:18]: $ npm install --quiet --no-optional
[20:58:23]: ▸ npm WARN deprecated urix@0.1.0: Please see https://github.com/lydell/urix#deprecated
[20:58:24]: ▸ npm WARN deprecated resolve-url@0.2.1: https://github.com/lydell/resolve-url#deprecated
[20:58:24]: ▸ npm WARN deprecated left-pad@1.3.0: use String.prototype.padStart()
[20:58:24]: ▸ npm WARN deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
[20:58:24]: ▸ npm WARN deprecated request-promise-native@1.0.9: request-promise-native has been deprecated because it extends the now deprecated request package, see https://github.com/request/request/issues/3142
[20:58:25]: ▸ npm WARN deprecated har-validator@5.1.5: this library is no longer supported
[20:58:26]: ▸ npm WARN deprecated fsevents@1.2.13: fsevents 1 will break on node v14+ and could be using insecure binaries. Upgrade to fsevents 2.
[20:58:51]: ▸ npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.2.7 (node_modules/jest-haste-map/node_modules/fsevents):
[20:58:51]: ▸ npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
[20:58:51]: ▸ npm WARN @vue/test-utils@1.0.4 requires a peer of vue@2.x but none is installed. You must install peer dependencies yourself.
[20:58:51]: ▸ npm WARN @vue/test-utils@1.0.4 requires a peer of vue-template-compiler@^2.x but none is installed. You must install peer dependencies yourself.
[20:58:51]: ▸ npm WARN vue-jest@4.0.0-beta.5 requires a peer of jest@^25.x but none is installed. You must install peer dependencies yourself.
[20:58:51]: ▸ npm WARN vue-jest@4.0.0-beta.5 requires a peer of vue@^2.x but none is installed. You must install peer dependencies yourself.
[20:58:51]: ▸ npm WARN vue-jest@4.0.0-beta.5 requires a peer of vue-template-compiler@^2.x but none is installed. You must install peer dependencies yourself.
[20:58:51]: ▸ npm WARN ts-jest@25.5.1 requires a peer of jest@>=25 <26 but none is installed. You must install peer dependencies yourself.
[20:58:51]: ▸ npm WARN ts-jest@25.5.1 requires a peer of typescript@>=3.4 <4.0 but none is installed. You must install peer dependencies yourself.
[20:58:51]: ▸ added 618 packages from 466 contributors and audited 621 packages in 33.069s
[20:58:52]: ▸ 29 packages are looking for funding
[20:58:52]: ▸ run `npm fund` for details
/usr/local/bundle/bin/fastlane: [!] No www found in root of project. (RuntimeError)

Unsure but isn’t AppFlow a paid service? If so you should use your included support :blush:

I’m using the free plan, wanna make sure it works with my project at the very least before diving deeper :stuck_out_tongue: