iOS simulator: livereload causes "deviceready has not fired after 5 seconds"


I can’t use the livereload option with emulate like this : ionic emulate ios -lcs because it leads to this error:

deviceready has not fired after 5 seconds

If I just do ionic emulate ios -cs though, I don’t have this issue.
The simulator launches automatically with iPhone 6 and iOS 9.
I have applied the patches recommended in the blog post.
I tried to remove and add the platforms again (ionic platform remove ios android).

Here’s my config:

$ ionic info

Your system information:

Cordova CLI: 5.3.3
Ionic Version: 1.1.0
Ionic CLI Version: 1.7.7
Ionic App Lib Version: 0.6.3
ios-deploy version: 1.8.2 
ios-sim version: 5.0.3 
OS: Mac OS X El Capitan
Node Version: v4.2.1
Xcode version: Xcode 7.1 Build version 7B91b 

$ionic plugin list
cordova-plugin-console 1.0.1 "Console"
cordova-plugin-device 1.0.1 "Device"
cordova-plugin-globalization 1.0.1 "Globalization"
cordova-plugin-googleplayservices 19.0.3 "Google Play Services for Android"
cordova-plugin-googleplus 4.0.3 "Google+"
cordova-plugin-network-information 1.0.1 "Network Information"
cordova-plugin-splashscreen 2.1.0 "Splashscreen"
cordova-plugin-statusbar 1.0.1 "StatusBar"
cordova-plugin-whitelist 1.0.0 "Whitelist"
cordova-plugin-x-socialsharing 5.0.5 "SocialSharing"
ionic-plugin-keyboard 1.0.7 "Keyboard"
phonegap-facebook-plugin 0.12.0 "Facebook Connect" 0.1.7 "AppVersion"

It’s really tough to debug an app without livereload, can someone help me on this ?

Really pissed me off too.
After some search rm -r platform/ios, rm plugins/ios.json and platform add ios made all back to normal.

I did that and now I have another error in the command line:


The following build commands failed:
	CompileXIB BoardLine/Classes/MainViewController.xib
(1 failure)
Error code 65 for command: xcodebuild with args: -xcconfig,...

then the second build worked and then I don’t have the deviceReady error anymore…
Thanks !