Ionic CLI livereload causes errors: deviceready has not fired after 5 seconds

When using “ionic run android -l -c -s” I always get the following error:

0 155038 log deviceready has not fired after 5 seconds.
1 155062 log Channel not fired: onPluginsReady
2 155064 log Channel not fired: onCordovaReady
3 155064 log Channel not fired: onDOMContentLoaded

removing -l seems to be resolving the issue and normal builds run fine.

1 Like

Yeah, I’m getting the same issue - anyone know what’s up?

Hmm, what platform are you seeing this?

Im on android right now…havent tested it with ios yet.

I could be completely off with this but i think it is caused because my app got too big to be loaded by wifi in less than 5 seconds because when i watch the server logs files are still transfered when the error message is thrown

Hmm, yeah that could be an issue. Thats got to be a big app :smile:

Yes, I’ve been getting the same error on iOS.

Is you’re app rather large?

I’m getting these messages running ionic emulate ios -l

6 566742 log deviceready has not fired after 5 seconds.
7 566745 log Channel not fired: onCordovaInfoReady
8 566746 log Channel not fired: onFileSystemPathsReady
9 566750 log Channel not fired: onCordovaConnectionReady

My platforms/ios folder is around 70mb

My app is very small, just the standard Ionic Tabs app with Auth0 integrated.

Is there a way to increase the timeout? I’ve been looking everywhere with no luck.

I would also like to increase the timeout period if that parameter is configurable. By adding Crosswalk to the project I increased the size, so (I suspect) that the app can’t load within 5 seconds.

1 Like

Looks like it is linked to crosswalk

Have the same problems on Android.
Any news on this ?
Any way to increase the timeout of the deviceready?

would be great to know if the crosswalk team is working on this, more an more topics about this bug start to open on the forum here.

Livereload is really amazing so hope this will work soon again with cordova plugins :smile:

I am not using crosswalk and still have the same problem, so I doubt its crosswalk related

I saw this last night as well randomly on the ionic livereload console logs on android device. using RC2.

I am getting the same error in osx and in windows

Finally managed to resolve this! In my case it was caused because I was trying to access the device plugin before device ready was called. I am not sure if this can be caused by trying to access other plugins too early but it is definitely caused with the device plugin. Enclosing the call in $ionicPlatform.ready(function () { … }) has removed the problem both in osx and windows platforms.

1 Like

Where can i check the plugins are loaded early before device ready. My code is in platform.ready. i am using ionic 2.1.1.

yes, i am also going through the same pain and there’s no turn around other than angular boostraaping.

please suggest the solution,what if i placed my code of ionicplatform.ready into deviceready.