Ios-sim Does not recognize devices after xCode 10.2 update

#1

Hello there!

After upgrading to xCode 10.2 I am experiencing one really bad issue. It is not possible to emulate/run application with live reload functionalities anymore. To be more precise, after xCode 10.2 installation finished, and xCode command line tools updated, Cordova (ios-sim) does not recognize any virtual device as simulator). Therefore command

ios-sim showdevicetypes

returns empty list.

Steps I have tried to resolve this issue:

  1. I have tried to update ios-sim to latest version *8.0.0. issue persists.
  2. I have tried to roll back to xCode 10.1 while deleting Library/Developer files, issue persists.
  3. Tried to complately remove Ionic and Cordova, reinstalled it, issue persists.
  4. Tried to raise iOS platform from 4.5.4 to 5.0.0, issue persists.

Command xcrun simctl list devices returns all available iOS sim simulator runtimes:

– iOS 12.2 –
iPhone 5s (BE2D764F-72C0-401C-8E12-8E32BA502037) (Shutdown)
iPhone 6 (F07425AE-7712-43B1-B987-8EEEFBE9908F) (Shutdown)
iPhone 6 Plus (59B39758-1EC4-4EF6-9A2E-0DD1F87ADC8E) (Shutdown)
iPhone 6s (18AB9159-BF51-4846-89A5-5D5A88194297) (Shutdown)
iPhone 6s Plus (B557EDB4-15F6-4B7F-AB71-FC5354689954) (Shutdown)
iPhone 7 (2439EBDD-D458-48B4-B524-DA850C311775) (Booted)
iPhone 7 Plus (A3739703-A36A-44D9-B82E-62D3666CA853) (Shutdown)
iPhone 8 (041E4CA5-7C33-4500-9438-119F247173BE) (Shutdown)
iPhone 8 Plus (707D8549-EF3E-454E-BC7A-593B3EC0E6D3) (Shutdown)
iPhone SE (63BF90ED-E85C-4BC7-B441-AA082C43A83D) (Shutdown)
iPhone X (3D7B6980-1783-491A-8F81-09FB3A83519E) (Shutdown)
iPhone Xs (C101781E-C0B0-43E4-95F7-C8775B47364A) (Shutdown)
iPhone Xs Max (24FF049A-41B2-4D50-BB04-049A0B2E8263) (Shutdown)
iPhone Xʀ (F4C441F2-6A0A-4DA4-83E4-59E4ABC9681D) (Shutdown)
iPad Air (3rd generation) (7198A0F4-B6A2-4512-BDAC-EA2041F46988) (Shutdown)
iPad Air (8FBB55F1-BD4E-402C-A62F-0581DC475068) (Shutdown)
iPad Air 2 (618CC9E8-8650-48F7-82CA-CA14116B7F5A) (Shutdown)
iPad (5th generation) (A63454F5-C9A3-4CA0-9815-97D3DC2BE46B) (Shutdown)
iPad Pro (9.7-inch) (0E69CDE8-E3DF-473F-AED1-3A30510D55CD) (Shutdown)
iPad Pro (12.9-inch) (BD88CF91-D337-407F-BD39-38E78023E87B) (Shutdown)
iPad Pro (12.9-inch) (2nd generation) (85C6DB40-30E9-4C97-BF73-13C5879BBBEC) (Shutdown)
iPad Pro (10.5-inch) (33CDC48E-5DA3-4C94-875E-26BAC12B9AF2) (Shutdown)
iPad (6th generation) (31C898B4-32EB-4ECD-99FA-E1451F2B691C) (Shutdown)
iPad Pro (11-inch) (5CD62E06-A349-4DE0-A31E-2AAB6683CD33) (Shutdown)
iPad Pro (12.9-inch) (3rd generation) (70F10A2E-07A5-45A7-A5B8-4B27BB682544) (Shutdown)

I guess this has something to do with ios-sim and cordova not being able to recognize new devices. Therefore, command
ionic cordova run ios -lc --target …

is not going to work. Cordova live connect server will run but when I try to debug application via Safari web inspector code wont show in web inspector.

Does anybody have simmilar issues with ios-sim? I dont think this has anything to do with ionic 3 or ionic4 platform. I have tried to replicate same issue on new ionic3/ionic4 projects, same thing happens.

#2

try this:

ionic cordova run ios -l -c -s --target="iPhone-X,com.apple.CoreSimulator.SimRuntime.iOS-12-2"  -- --buildFlag="-UseModernBuildSystem=0"

… the runtime needs to be specified with this format instead… don’t update ios-sim

3 Likes
Problems to emulate after xCode update
#3

There’s an open issue on ios-sim repo. Should wait for a fix.