iOS 17 requirement for Apple appstore submissions

Is Capacitor 6 required to build for iOS 17? If not, how does one force iOS 17 compatibility for my appflow builds?

For building with iOS 17 SDK all you need to do is to use Xcode 15 to build your app.

In Appflow terms that means using build stacks macOS - 2023.09 or macOS - 2023.10