iOS SDK 16.1 - Capacitor Support?

When I build my app for iOS, and then try to distribute it to the app store I get this warning: Starting April 2023, all iOS apps submitted to the App Store must be built with the iOS 16.1 SDK or later, included in Xcode 14.1 or later.

I have not been able to figure out how to use the iOS 16.1 SDK with Capacitor. What is the solve for this?

The warning is quite clear. You need xcode 14.1 minimum, do you build the app on your pc or via appflow?

I build on my MacBook straight from xcode. I don’t know much about xcode beyond just getting my app distributed to the app store. What do you suggest I do?

check what Xcode version you have installed. I guess it’s below 14.1 - than upgrade it

You can check the Xcode version by clicking Xcode → About Xcode

You can update Xcode by opening App Store app, latest version is 14.2

Hi, @EinfachHans how to solve the error if I build it via AppFlow?

I have been scratching my head and will appreciate any help on this.

For appflow you have to use a stack that has Xcode 14.1 or newer installed

According to this stacks table you have to use macOS - 2023.03