Ionic update platform removes Cordova lib from project

Ionic by default adds iOS platform 4.1.1 to the project. But for the urbanairship-cordova plugin requires 4.3.0. It throws below message,

“Plugin doesn’t support this project’s cordova-ios version. cordova-ios: 4.1.1, failed version requirement: >=4.3.0”

When I tried removing iOS platform and re-added it using ionic platform add ios.It updates cordova-ios to 4.3.0 but cordova lib gets removed from the app.

Is there any workaround for this?

Attached is screen shot for reference,

  1. ionic create myApp blank command creates a project with cordova iOS 4.1.1, the cordovalib is there

enter image description here

  1. After updating to cordova-ios 4.3.0, it removes the cordovalib

enter image description here

my system information:

Cordova CLI: 6.4.0

Ionic CLI Version: 2.1.18

Ionic App Lib Version: 2.1.9

ios-deploy version: 1.9.0

ios-sim version: 5.0.13

OS: macOS Sierra

Node Version: v6.9.2

Xcode version: Xcode 8.2.1 Build version 8C1002

This happens to me also, every time. I tried ionic platform rm ios followed by cordova platform add ios and got the CordovaLib but cannot do this with ionic.