Cordova 4.0 compatibility


#1

I know it’s super early, but is Ionic compatible with Cordova 4.0?


#2

I’m wondering the same thing, as google dev console is giving me the following warning:

"This app is built on a version of Apache Cordova that contains security vulnerabilities. This includes a high severity cross-application scripting (XAS) vulnerability."

Not sure what version I should update cordova to.


#3

I think @nokturnal is talking about the CLI? because the newest versions of the platforms is 3.6.3 and 3.6.4.

You can update your platforms to the newest one: cordova platform update ios
You can also install a specific platform like this: ionic platform add android@3.5.1
To see what versions of each platform you got you can do: cordova platforms

I use cordova CLI 4.0 and it seems to work fine. xCode 6.1 though… not so good…


#4

We’re talking about the CLI indeed. Is there a way to update an ios app to e.g. cordova 3.6.1. I’m getting the following errors if I just try to update:

cordova platform update ios
Error: No compatible version found: cordova-ios@'>=8458588.0.0-0 <8458589.0.0-0'
Valid install targets:
["3.5.0","3.6.0","3.6.1","3.6.3"]

cordova platform list
Installed platforms: android 3.6.4, ios 3.4.1

I’d like to update to ios 3.6.3

I tried this with no luck:

cordova platform update ios@3.6.3
Platform "ios@3.6.3" is not installed. See `cordova platform list`.

Thanks for your help!


#5

What version of the CLI do you have (cordova -v)? you maybe have to upgrade it?
ex:

sudo npm install -g cordova@3.7.0

#6
cordova -v
4.0.1-nightly.2014.9.29

#7

oh! well then cordova update ios should work… Maybe you have to remove and then add ios platform again


#8

Thanks, I’ll try that.