Ionic serve - weird livereload

I have just installed the newest version of ionic and started a new sidemenu project. Now when I do ionic serve the app is opened in my browser. If I remove the code within ion-content from home.html now and insert “Test”, the page is reloading but it is still showing the old output with the headline and button. If I reload the page with ctrl + F5, there is the correct output “Test”. But if I change the code again to “Test1” and save the file, the page is reloading again and then the old output with the headline and button appears again. Even if I stop ionic serve and start it again, it is showing this. Whats going on there? Here is my ionic info:

global packages:

    @ionic/cli-utils : 1.5.0
    Ionic CLI        : 3.5.0

local packages:

    @ionic/app-scripts              : 2.0.2
    @ionic/cli-plugin-ionic-angular : 1.3.2
    Ionic Framework                 : ionic-angular 3.5.3


    Node       : v7.6.0
    OS         : Linux 4.8
    Xcode      : not installed
    ios-deploy : not installed
    ios-sim    : not installed
    npm        : 4.1.2

A post was split to a new topic: “err_internet_disconnected”

Did you “uncomment” the service worker in index.html?

@Sujan12 Sorry for the late answer. Yes I did first, but if I comment it again there is still the same problem.

EDIT: And there is the same problem if I do a fresh ionic start.

EDIT2: On Firefox it is working. Before I only tried it on Chrome and there it was not working

So the service worker doesn’t matter?

Seems like, because I had the same problem with a new project where it was still commented. On firefox it is working now, except when I press F5. Then I’m getting Runtime Error “modules[moduleId] is undefined”. But if I press CTRL + F5 then it is working again.

Hi together,

I have the same problem: in my Ionic app everything was working fine - until I uncomment the service worker part inside the index.html. Afterwards I comment this part again, but if I press F5 in Firefox, I get the runtime error “modules[modulesId] is undefined”. If I press STRG+F5 it works.

What is going wrong here? Is the reason the service worker (even if I comment the part again)?

Anybody created a Github issue (or looked if one already exists) for this?