Ionic livereload

I am getting this error in my console.
No response for http://localhost:35729/livereload.js?snipver=1 found in cache. About to fetch from network...

When I make a change to my app, the app reloads and builds but I do not see the changes in the browser.

Also, when I try ionic serve on another app, it reloads my current app.

When I go to http://localhost:8100/ my app is there even if I don’t use ionic serve.

I have done npm cache clean
removed ionic from computer and re-added.

But still get that error.

Can you run ionic info in the root directory of your project

cordova CLI: 6.4.0
Ionic Framework Version: 2.0.0-rc.3
Ionic CLI Version: 2.1.18
Ionic App Lib Version: 2.1.9
Ionic App Scripts Version: 0.0.48
ios-deploy version: Not installed
ios-sim version: Not installed
OS: Windows 10
Node Version: v4.6.0
Xcode version: Not installed

UPDATE: I have uninstalled ionic, cordova and npm. Then re-installed… Now the error No response for http://localhost:35729/livereload.js?snipver=1 found in cache. About to fetch from network... is removed.

But when I use ionic serve on an app it shows, but doesn’t show the changes I make.
I get this error now… Service Worker termination by a timeout timer was canceled because DevTools is attached.

Since that error is browser related, I tried my app in incognito so no extensions can have an affect. Then HOORAH! it worked.

I think Adblocker extension was the cause or one of the extensions.

I’ve had similar issues with ionic serve. has taken me a week to find the solution:

clear browser and hosted app data on chrome. all good again.

my app was working on emulate and, i discovered today, on opera browser, but for the last week or so has been doing really strange things on chrome, like always loading an old app i have long since deleted which didn’t work. whenever i served up another app to the browser, it kept running this old app.

1 Like

It happened to me now and I solved it by opening the page with my local ip address instead of localhost.

If you are running on Windows you can open the CMD and type ipconfig. This will retrieve your local ip address. Your ip address should be at Adaptador Ethernet Ethernet -> IPv4 Address .

For example, if your ip is 10.1.1.15 you should open http://10.1.1.15:8100/ in your browser so that you can use live reload.

Yep, I solved it by clearing browser and hosted app data on chrome as @jdm79 suggested :slight_smile:

A weird and annoying problem.

Even after re-install, Chrome cache + hosted app clear - still opened old cached app.

By adding http://localhost:8100/#/ in the browser window, it seemed to refresh it and can now access again via http://localhost:8100

This works for me. But only as a temporary solution. Once I clear old cached app, then the latest app is shown but any future changes are not reloaded. Have started to use Firefox developer tools until I can resolve this.

cli packages: (/Users/padraigoleary/GitHub/rheumaiq_app/node_modules)

@ionic/cli-plugin-cordova       : 1.6.2
@ionic/cli-plugin-ionic-angular : 1.4.1
@ionic/cli-utils                : 1.7.0
ionic (Ionic CLI)               : 3.7.0

global packages:

Cordova CLI : 7.0.1

local packages:

@ionic/app-scripts : 1.3.12
Cordova Platforms  : android 6.2.3 ios 4.4.0
Ionic Framework    : ionic-angular 3.5.0

System:

Android SDK Tools : 26.0.2
Node              : v8.1.4
OS                : macOS Sierra
Xcode             : Xcode 8.3.3 Build version 8E3004b
ios-deploy        : 1.9.0
ios-sim           : 5.0.9
npm               : 5.0.3

Resolved my issue -

I had enabled the service work by uncommenting the script tag for it in src/index.html without looking at what it does. Thought I just needed that to get the ‘install to homescreen’ progressive web app functionality for chrome browsers. Turns out service-worker.js caches key assets and they get picked up on rebuild instead of what ionic has just built.

Ref: https://github.com/ionic-team/ionic-app-scripts/issues/363