Ionic runs on emulator but not in real device

I have install ionic 2 template application.
On emulator application runs OK, but on actual device android 4.1.2 I see only white screen.
I have try to debug app with ionic run android --consolelogs --livereload but i don’t see any error.
I tried to add crosswalk plugin to the application but no luck with that. :frowning:

Application should run on my real android 4.1.2 (LG-E440) device.

Steps to reproduce:

  1. Follow instructions:
  2. Take 4.1.2 Android and try to run application.
  3. Application should show only white screen…

Ionic info:

Cordova CLI: 6.0.0
Gulp version:  CLI version 3.9.1
Gulp local:   Local version 3.9.1
Ionic Version: 2.0.0-beta.3
Ionic CLI Version: 2.0.0-beta.19
Ionic App Lib Version: 2.0.0-beta.9
OS: Distributor ID:     Ubuntu Description:     Ubuntu 14.04.3 LTS 
Node Version: v5.3.0

This is a recent change made to newer releases to cordova. As part of a security fix, they block live reload on the server for now. We’re looking into what we can do to fix this.

Well the problem is that I see white application screen even when I run ionic run android.
Why is this happening? Oh and one more thing at the end where it should write:


I see only:


Is this indicate something that is related to this problem?

You may try building 'a test version’
With our very cute ionic build android.

Another thing is probably because SASS has not been compiled. I had this problem when I downloaded a template which was using imports from ionic-angular instead of the regular ionic-framework/ionic or even the ionic/ionic I was used to. Try running ionic setup sass to see if it solves the problem

–livereload don’t work on android below version 4.4 for me too (old browser engine). So I test it without this flags :slight_smile:

PS I’ll try use crosswalk, maybe it’s fix the issue.

I tryed ionic setup sass but problem perssist. I think there is the issue that I see only:


when I run ionic run android.

But when I run ionic run android --emulator I see:


This is really bugs me at the core of my heart. Why on emulator is working all fine but not in the real device, why the real device is so different to emulator. :sweat:

Oh and yes I have tried to install apk with adb install android-debug.apk but white screen is still there.

I have the same issue, when i launch my app on android 4.3 i can see splash screen but after it’s just white screen. Like you urosjarc it works in my emulator :frowning:

Oh Android 4.3 is having the same problem!
This is pain in the ass. I think that the best thing is to add issue to ionic 2.

I opened it, this is the answer of Ionic I add it and my app is going from 1 to 17Mo

[cordova run android --emulator] (run app on emulator update lastest sdk android in android studio)
[cordova run android] (run on your device connect by usb with debug mode)

Don’t use these commands, use the ionic equivalents so everything is correctly built before:

ionic cordova emulate android
ionic cordova run android

OK thank, I get the problem when I use my commands it is only build the code before no change anything.