Ionic run ios failed (error 65) after successful build ios


#1

I have some strange behavior.

I am able to ionic build ios and ionic emulate ios with no problems.

However I get the following error when I do an ionic run ios to my device. I get the same error on three other apps I’ve successfully deployed to my device too.

I tried tips from other threads on this forum:

  1. remove platform ios and plugins
  • reinstall platform and then plugins
  • test build ios and emulate ios, all good
  • test run io no dice, same error

Here’s the error I’m getting:

** BUILD FAILED **

The following build commands failed:
	Ld build/device/MyApp.app/MyApp normal armv7
(1 failure)
Error: ~/MyApp/platforms/ios/cordova/run: Command failed with exit code 65
    at ChildProcess.whenDone (/~/.nvm/v0.10.29/lib/node_modules/cordova/node_modules/cordova-lib/src/cordova/superspawn.js:135:23)
    at ChildProcess.emit (events.js:98:17)
    at maybeClose (child_process.js:755:16)
    at Process.ChildProcess._handle.onexit (child_process.js:822:5)

Any thoughts?


#2

Some more information.

I removed my plugin list and started to add them back in one by one. It turns out that everything works fine until I add the com.google.cordova.admob plugin. Once I have that in there I get the above error.

This plugin was working fine before. The only changes I can think of that I’ve made are related to UI and a few controller js changes.

I am going to run some tests around fresh projects using only this plugin to see if there are any conflicts.

Below is some information about my setup:

$ionic -v
1.2.8

$cordova -v
4.0.0

$cordova plugin list
cc.fovea.cordova.purchase 3.9.0-beta.1 "Purchase"
com.danielcwilson.plugins.googleanalytics 0.6.0 "Google Universal Analytics Plugin"
com.google.admobsdk 6.12.0 "AdMob SDK for Android, iOS and WP8"
com.google.cordova.admob 2.3.2 "AdMob PluginPro with Mediations"
com.google.playservices 19.0.0 "Google Play Services for Android"
com.rjfun.cordova.ad 1.0.1 "Generic Ad"
com.rjfun.cordova.ext 1.0.0 "Cordova Plugin Extension"
org.apache.cordova.console 0.2.11 "Console"
org.apache.cordova.device 0.2.12 "Device"
org.apache.cordova.inappbrowser 0.5.3 "InAppBrowser"
org.apache.cordova.network-information 0.2.13 "Network Information"
org.apache.cordova.splashscreen 0.3.4 "Splashscreen"
org.apache.cordova.statusbar 0.1.8 "StatusBar"

#3

Ok, I’ve made progress on this, so posting to help anyone who might run into this.

First the issues all seem to related to updates I made to OSX/Xcode. After I made them I was no longer to make do a build on a project I had previously built and deployed to the device.

The updates to my OSX setup seemed to have forced that a Metal for architecture armv7 library be installed in order to deploy to my device, the emulator worked fine.

To fix I updated my mac to the latest version of xcode, ionic, cordova and command line tools.

$ionic -v
1.2.8
$cordova -v
4.1.2

Xcode: Version 6.1 (6A1052d)

I then had to update some npm packages involved in deploying:

sudo npm install -g grunt-contrib-concat
sudo npm install -g ios-sim  
sudo npm install ios-deploy 

Then finally removed my ios platform ionic platform rm ios and plugins and reinstalled.

Hope this helps.


#4

I have the same issue only it happens when I add cordova-plugin-facebook4. I created a new ionic app and kept deploying to iOS then added dependencies. It worked until I added cordova-plugin-facebook4. I tried executing your steps but it failed at sudo npm install ios-deploy.

ERROR:

/bin/mkdir -p /Users/laroca/Documents/Mundo/node_modules/ios-deploy/build/ios-deploy.build/Release/ios-deploy.build
error: Unable to create directory: /Users/laroca/Documents/Mundo/node_modules/ios-deploy/build/ios-deploy.build/Release/ios-deploy.build (Permission denied)
/bin/mkdir -p /Users/laroca/Documents/Mundo/node_modules/ios-deploy/build/ios-deploy.build/Release/ios-deploy.build
error: Unable to create directory: /Users/laroca/Documents/Mundo/node_modules/ios-deploy/build/ios-deploy.build/Release/ios-deploy.build (Permission denied)
/bin/mkdir -p /Users/laroca/Documents/Mundo/node_modules/ios-deploy/build/ios-deploy.build/Release/ios-deploy.build
error: Unable to create directory: /Users/laroca/Documents/Mundo/node_modules/ios-deploy/build/ios-deploy.build/Release/ios-deploy.build (Permission denied)