Error on ionic run ios


#1

Hello everyone

I am working on a new project and havn’t changed much on the ionic blank starter.
I added the android and ios platform without any errors, then i built for android with

ionic build android

worked perfectly fine, but when i ran

ionic build ios

i got tons of EACESS/permissions errors. so to make sure the softwork is fine i run

npm uninstall -g ionic cordova ios-sim ios-deploy
npm install -g ionic cordova@5.0.0 ios-sim ios-deploy

i still had the same errors so i first gave permissions to the hook directory and afterwards to all files to see if it made any difference

sudo chmod 777 *

in fact i was now able to build and run with the ionic build/run ios command for the simulator
so i tried to test the application on my device with ionic run ios --device
according to the logs it found my device but then i got an error messge that ios-deploy quit unexpectedly

i also tried to install the application via Xcode - i opened the .xcodeproject file under platforms/ios
-> xcode opened the project and startet to "processing symbol files
it then quit unexpectetly and i got a similar error message like before

does anyone has a solution for this problem or experienced the same in the past ?

by the way these are my system informations:
Your system information:

Cordova CLI: 5.0.0
Gulp version: CLI version 3.9.0
Gulp local:
Ionic Version: 1.0.1
Ionic CLI Version: 1.6.3
Ionic App Lib Version: 0.3.7
ios-deploy version: 1.7.0
ios-sim version: 4.1.1
OS: Mac OS X Yosemite
Node Version: v0.12.4
Xcode version: Xcode 6.4 Build version 6E35b