'ionic' is not recognized as an internal or external command

I don’t know if anyone experienced this. The holidays were busy and I didn’t get a chance to work with ionic. Now, I tried to use the command tool and is not working. Ionic is MIA, Weird. Anyways, I clean the cache, ‘npm cache clean’, and re-install ionic. It works now.

Yeah, I seem to be experiencing the same… The last thing that I recall doing was upgrading after seeing the prompt on the CLI to do so… I continued using ionic for the next couple of days without issue in that same command window (I’m in Windows), but after closing the command prompt window and opening a new one, ionic is not recognized as a command… Guessing this isn’t desired… Will try to reinstall, but not quite sure why it is that this happened to begin with…

Check if the configuration is broken or not. the update might have installed it in the wrong place.

First check: npm config get prefix

In my case It wasn’t set to /usr/local but in /usr/Roaming.

So to fix it, use: npm config set prefix

Problem solved! :smile:

does not working… it keeps me re.installing this ionic app before it works…