'ionic build', 'ionic run' doesn't work, but it doesn't return any error


I have a problem.
Any ‘build’ and ‘run’ commands don’t work, but it doesn’t return any error.

ionic build ios
ionic run ios
ionic build android
ionic run android

My system information is

Cordova CLI: 5.3.3
Gulp version: CLI version 3.9.0
Gulp local:
Ionic Version: 1.1.0
Ionic CLI Version: 1.7.7
Ionic App Lib Version: 0.6.3
ios-deploy version: 1.8.2
ios-sim version: 5.0.3
OS: Mac OS X El Capitan
Node Version: v5.0.0
Xcode version: Xcode 7.1 Build version 7B91b

I tried to
・reinstall cordova and ionic
・remove ~/.cordova directory
・remove ~/.ionic directory
But it didn’t change.

Please give me some advices.

Thank you.

me too. How to solve??

I’m adding myself to this. Everything stopped working since yesterday morning. Not sure if it is related to any of the dependency getting upgraded like node. But “build”, “run”, “emulate” none of those are working and no errors are thrown. “serve” still works.

I was able to resolve the issue. In my case it was the latest version of node v5.0.0. I installed a previous version via nvm https://github.com/creationix/nvm and everything is back to normal with Ionic cli.

Steps to follow:

  1. Install nvm via curl -o- https://raw.githubusercontent.com/creationix/nvm/v0.29.0/install.sh | bash
  2. close and reopen your shell
  3. run ‘nvm install 4’ this will installed the latest version before 5.0.0
  4. try ionic build and run. It should be working again

Thank you very much!!
It worked.

Have a nice day. :grinning:

yes.It worked for me too.
thank you.

In ArchLinux I solved by going to http://ala.seblu.net/packages/ and downloading ‘icu’ version 55 and ‘nodejs’ version 4.2. Then in the console you must run “sudo pacman -U the downloaded package” for each package.

Thank you so much! I spent so much time trying to figure this out and then stumbled on your solution. Really appreciate it! Thanks again!

Is there any official place that tracks Ionic effort to work on Node 5.0, or some pre release version that is supposed to work with it?

No way, if you use kde 5, which required icu 56

I finally got it working. I just needed to uninstall Cordova and Ionic and install them again.